Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1158412 - [3.5-6.6] CIM funtion doesn't work
Summary: [3.5-6.6] CIM funtion doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1166272
Blocks: rhev35rcblocker rhev35gablocker 1167093
TreeView+ depends on / blocked
 
Reported: 2014-10-29 10:28 UTC by cshao
Modified: 2016-02-10 20:02 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1167093 (view as bug list)
Environment:
Last Closed: 2015-02-11 21:05:20 UTC
oVirt Team: Node
Target Upstream Version:
scohen: needinfo+


Attachments (Terms of Use)
cim.tar.gz (deleted)
2014-12-18 07:49 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 34554 node-3.0 MERGED SElinux changes for CIM Never
oVirt gerrit 36713 None None None Never

Description cshao 2014-10-29 10:28:14 UTC
Description of problem:
CIM funtion doesn't work, it can not get info through CIM when configured it.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.6-20141027.0.iso
(http://download.devel.redhat.com/brewroot/work/tasks/2138/8162138/rhev-hypervisor6-6.6-20141027.0.iso)
ovirt-node-3.0.1-19.el6.21.noarch

How reproducible:
100%

Test steps:
1. Install rhev-hypervisor6-6.6-20141027.0.iso.
2. Enabled network
3. Configure CIM in TUI with setting password as 'redhat'
4. Check CIM function from remote as follows.
# wbemcli ein -noverify https://cim:1@ip/root/virt:KVM_VirtualSystemManagementService

Actual results:
1. After step4, it shows http exception as follows.
*
* wbemcli: Http Exception: Invalid username/password.
*

Expected results:
1. It can get rhevh info through CIM after configured it.

Additional info:
No such issue on 
RHEV-H 6.5u8 for RHEV 3.4.3 (rhev-hypervisor6-6.5-20141017.0).

Comment 1 Ryan Barry 2014-11-20 17:17:48 UTC
FYI, this will also affect 3.5 on 6.6, since it's a platform problem.

Comment 8 cshao 2014-12-18 07:49:00 UTC
Test version:
rhev-hypervisor6-6.6-20141212.0.iso
ovirt-node-3.1.0-0.34.20141210git0c9c493.el6.noarch

Test steps:
1. Install rhevh
2. Enabled network
3. Configure CIM in TUI with setting password as 'redhat'
4. Check CIM function from remote as follows.
# wbemcli ein -noverify https://cim:redhat@ip
root/virt:KVM_VirtualSystemManagementService

Test result:
CIM function still doesn't work.

===================
# wbemcli ein -noverify https://cim:redhat@10.66.10.8/root/virt:KVM_VirtualSystemManagementService
*
* wbemcli: Http Exception: Invalid username/password.
*

So change bug status to ASSIGNED.

Comment 9 cshao 2014-12-18 07:49:30 UTC
Created attachment 970435 [details]
cim.tar.gz

Comment 10 Ryan Barry 2014-12-18 14:23:34 UTC
This depends on platform bz#1102477 and cannot be tested until that bug is resolved and an image which includes the updated package is available.

Comment 11 Fabian Deutsch 2015-01-05 09:05:07 UTC
Adding the blocking 6.6.z bug: 1172821

Comment 12 Ryan Barry 2015-01-08 20:24:58 UTC
Builds with fixed CIM packages revealed another selinux denial, after which CIM works as expected.

Patch is pending upstream. New images will be available tomorrow. If I have time today, I'll try to get a scratch build out for testing.

Comment 13 cshao 2015-01-19 05:23:07 UTC
Test version:
rhev-hypervisor6-6.6-20150114.0
ovirt-node-3.2.1-4.el6.noarch

Test steps:
1. Install rhevh
2. Enabled network
3. Configure CIM in TUI with setting password
4. Check CIM function from remote as follows.
# wbemcli ein -noverify https://cim:redhat@ip
root/virt:KVM_VirtualSystemManagementService

Test result:
CIM can work fine, it can get rhevh info through CIM after configured it.

So the bug has been fixed, change bug status to VERIFIED.

Comment 15 errata-xmlrpc 2015-02-11 21:05:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.