Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 115701 - text file printed through class is not converted properly
Summary: text file printed through class is not converted properly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2004-02-15 02:54 UTC by Jonathan Kamens
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-13 15:19:50 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2004-02-15 02:54:40 UTC
I have a class definition in /etc/cups/classes.conf created using the
Web interface at http://localhost:631/.  It looks like this:

<Class final>
Info final
State Idle
Accepting Yes
JobSheets none none
Printer lj1100-final
QuotaPeriod 0
PageLimit 0
KLimit 0
</Class>

The printer lj1100-final is using the ljet4 driver and has the
"convert text to PostScript" option enabled.  If I print a text file
with "lpr -Plj1100-final", it comes out just fine -- the correct
margins are set, etc.  If, however, I print a text file with "lpr
-Pfinal", the correct margins are not set and the text is therefore
cut off at the top and the left.  It appears that somehow the driver
options set for the lj1100-final printer are ignored when printing
through the class.

I'm using cups-1.1.20-2 and foomatic-3.0.0-22.

Comment 1 Tim Waugh 2005-03-07 17:46:54 UTC
*** Bug 150391 has been marked as a duplicate of this bug. ***

Comment 2 Joe Harrington 2005-04-21 21:21:27 UTC
There seem to be two problems here:

1) as reported here, the driver settings are ignored when printed through the class

2) as reported on bug 150391, ascii submitted to lpr is printed without any
margins and gets cut off.  I can confirm this.

I don't see these as duplicate bugs.

--jh--


Comment 3 Tim Waugh 2005-04-26 11:55:19 UTC
Confirmed.  I had thought that both involved classes, but (2) does not.

Comment 4 Tim Waugh 2006-04-24 13:07:24 UTC
Note to self: Need to re-test this in FC6 with CUPS 1.2 and network default
options instead of lpoptions.

Comment 5 Sitsofe Wheeler 2006-04-24 15:56:43 UTC
Perhaps this bug should have its version changed to devel given how long its
survived?

Comment 6 Tim Waugh 2006-10-13 15:19:50 UTC
Fixed in FC6 with network default options.


Note You need to log in before you can comment on or make changes to this bug.