Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 115188 - RTL8180 driver seg faults
Summary: RTL8180 driver seg faults
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-08 09:53 UTC by Noah White
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:08 UTC


Attachments (Terms of Use)

Description Noah White 2004-02-08 09:53:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Under RH9 this driver works. Built under Fedora Core-1 kernel
2.4.22-1.2149.nptl & gcc-3.3.2-1 it seg. faults.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Obtain sources from RealTek 

ftp://152.104.125.40/cn/wlan/rtl8180l/rtl8180_linuxdrv_v15_rh90.zip

2. 'make/make install' sources
3.  modprobe rtl8180_24x -> Segmentation Fault 
    

Actual Results:  Segmentation Fault

Expected Results:  Driver should load

Additional info:

RealTek and many posts on the net suggest that this driver builds and
installs fine under RH9 2.4.20 w/gcc-3.2.2.

Comment 1 Arjan van de Ven 2004-02-08 09:55:49 UTC
that's a nice binary only module -> not our problem

*** This bug has been marked as a duplicate of 78616 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.