Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1151827 - VM cpu hot plug succeed, though it exceeds Quota cpu limit
Summary: VM cpu hot plug succeed, though it exceeds Quota cpu limit
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Omer Frenkel
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
Depends On:
Blocks: 1073943 rhev35betablocker rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-10-12 12:12 UTC by Ilanit Stein
Modified: 2015-10-27 23:57 UTC (History)
15 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 08:26:11 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 34069 master MERGED core: dont copy old num of sockets on hotplug Never
oVirt gerrit 34084 ovirt-engine-3.5 MERGED core: dont copy old num of sockets on hotplug Never
oVirt gerrit 34085 ovirt-engine-3.5.0 MERGED core: dont copy old num of sockets on hotplug Never

Description Ilanit Stein 2014-10-12 12:12:25 UTC
Description of problem:
When setting quota to 1 cpu limit. VM with 1 cpu - cpu hot plug to or to 3, succeed!, though it should have failed, on quota cpu limit. 

Version-Release number of selected component (if applicable):
vt5

How reproducible:
100%

Additional info:
There was same bug, for 3.4, that was verified: 
https://bugzilla.redhat.com/https://bugzilla.redhat.com/1083177

Expected results:
User is violating the quota, the action should not be permitted.

Comment 2 Gilad Chaplik 2014-10-13 10:29:26 UTC
hotSetCpu command numOfSockets parameter is passed with no change.

Moving to virt.

Comment 3 Sandro Bonazzola 2014-10-14 12:59:25 UTC
Shouldn't this be in modified since all patches have been merged?

Comment 4 Omer Frenkel 2014-10-14 13:03:27 UTC
yes it was merged just now

Comment 5 Ilanit Stein 2014-10-19 11:59:44 UTC
Verified on vt6.
Now cpu host plug is working OK. Following UI cpu socket hot plug, A rhel6.5 guest 'lscpu' show indeed the number of cpus is updated.

Comment 6 Ilanit Stein 2014-10-19 13:05:44 UTC
Correction: This bug is NOT verified on vt6:

The cpu hot-plug is working on vt6, only in the situation where there is NO quota defined in the data center.
If adding a quota, of 1 vCPU, this bug still exist in vt6.

Comment 7 Ilanit Stein 2014-10-19 13:18:43 UTC
Eyal,

Would you please check if this fix is indeed included in vt6?

Thank you,
Ilanit.

Comment 9 Ilanit Stein 2014-10-19 13:38:01 UTC
My mistake, moving to verified.

When there is no quota cpu hot plug work ok (guest updated).
When there is a quota (num of cpu limit) the cpu host plug work, and blocked, when quota is exceeded.

Comment 10 Omer Frenkel 2015-02-17 08:26:11 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.