Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1149634 - [hosted-engine-setup] [iSCSI support] deployment gets stuck, VM enters to paused state
Summary: [hosted-engine-setup] [iSCSI support] deployment gets stuck, VM enters to pau...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Elad
URL:
Whiteboard: integration
Depends On: 1146529 1148712 1150427
Blocks: 1067162
TreeView+ depends on / blocked
 
Reported: 2014-10-06 09:56 UTC by Elad
Modified: 2015-02-11 20:41 UTC (History)
5 users (show)

Fixed In Version: ovirt-hosted-engine-setup-1.2.1-3.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:41:27 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
vdsm and setup logs (deleted)
2014-10-06 09:56 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0161 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2015-12-07 21:35:11 UTC

Description Elad 2014-10-06 09:56:13 UTC
Created attachment 944201 [details]
vdsm and setup logs

Description of problem:
During hosted-engine deployment, after the rhevm installaion on the VM, the VM got into paused state and the hosted-engine deployment got stuck in:

[ INFO  ] Still waiting for VDSM host to become operational...


Version-Release number of selected component (if applicable):
rhev3.5 vt4
ovirt-hosted-engine-setup-1.2.0-1.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. hosted-engine --deploy
2. pick iscsi
3. install OS and rhevm on the VM and continue the deployment


Actual results:
Installation gets stuck in:

          To continue make a selection from the options below:
          (1) Continue setup - engine installation is complete
          (2) Power off and restart the VM
          (3) Abort setup
         
          (1, 2, 3)[1]: 1
[ INFO  ] Engine replied: DB Up!Welcome to Health Status!
          Enter the name of the cluster to which you want to add the host (Default) [Default]: 
[ INFO  ] Waiting for the host to become operational in the engine. This may take several minutes...
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] Still waiting for VDSM host to become operational...

VM enters to Paused state:

[root@green-vdsb ~]# vdsClient -s 0 list table
33215ad5-a2b2-4339-a368-97e905d145db  20608  HostedEngine         Paused 


Expected results:
Deployment should be successful for iSCSI storage

Additional info: vdsm and setup logs

Comment 1 Elad 2014-10-06 15:49:13 UTC
Cannot find a workaround, there is no option to resume the VM without exit the installation

Comment 2 Sandro Bonazzola 2014-10-07 12:28:19 UTC
This should have been solved by new selinux-policy package and vdsm build.
Please re-test with VT5.

Comment 3 Elad 2014-12-24 14:02:13 UTC
I managed to deploy iSCSI on a RHEL6.6 host with the following packages installed:


libselinux-utils-2.0.94-5.8.el6.x86_64
libselinux-ruby-2.0.94-5.8.el6.x86_64
selinux-policy-targeted-3.7.19-260.el6_6.1.noarch
libselinux-2.0.94-5.8.el6.x86_64
libselinux-python-2.0.94-5.8.el6.x86_64
selinux-policy-3.7.19-260.el6_6.1.noarch

vdsm-4.16.8.1-4.el6ev.x86_64

ovirt-hosted-engine-ha-1.2.4-5.el6ev.noarch
ovirt-hosted-engine-setup-1.2.1-8.el6ev.noarch

sanlock-2.8-1.el6.x86_64


Used rhev 3.5 vt13.5

Comment 5 errata-xmlrpc 2015-02-11 20:41:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0161.html


Note You need to log in before you can comment on or make changes to this bug.