Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1147468 - Report "The specified OVF archive is not a valid OVF archive" during select boot vm from disk
Summary: Report "The specified OVF archive is not a valid OVF archive" during select b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: meital avital
URL:
Whiteboard: integration
Depends On:
Blocks: rhevh-7.0 rhev35betablocker rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-09-29 10:03 UTC by wanghui
Modified: 2016-07-04 00:39 UTC (History)
12 users (show)

Fixed In Version: ovirt-hosted-engine-setup-1.2.1-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:41:17 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
screen shot of the error (deleted)
2014-09-29 10:03 UTC, wanghui
no flags Details
provide log info (deleted)
2014-09-29 10:03 UTC, wanghui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0161 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2015-12-07 21:35:11 UTC
oVirt gerrit 33491 master MERGED ovf: allow empty image description Never
oVirt gerrit 33536 ovirt-hosted-engine-setup-1.2 MERGED ovf: allow empty image description Never

Description wanghui 2014-09-29 10:03:20 UTC
Created attachment 942266 [details]
screen shot of the error

Description of problem:
It reports error as "The specified OVF archive is not a valid OVF archive" during select boot vm from disk.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140926.0.iso
ovirt-node-3.1.0-0.17.20140925git29c3403.el7.noarch
ovirt-node-plugin-hosted-engine-0.2.0-2.0.el7.x86_64
ovirt-host-deploy-1.3.0-0.0.4.master.el7.noarch
ovirt-host-deploy-offline-1.3.0-0.0.2.master.el7.x86_64
ovirt-hosted-engine-setup-1.2.0-1.el7.noarch
ovirt-hosted-engine-ha-1.2.1-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean install rhev-hypervisor7-7.0-20140926.0.iso
2. File ova path in TUI
3. Click <Setup Hosted Engine>

Actual results:
1. First it will report error downloading OVA.(another issue will be reported separately)
2. After that, continue configure hosted engine, it will report error as rhevm-appliance.png shows.

Expected results:
1. It should run vm without error.

Additional info:

Comment 1 wanghui 2014-09-29 10:03:55 UTC
Created attachment 942267 [details]
provide log info

Comment 2 Fabian Deutsch 2014-09-29 11:27:53 UTC
Screenshot indeicates that the error is taking place during engine-setup.

Comment 3 Sandro Bonazzola 2014-09-29 11:38:05 UTC
looking at the setup logs:

 2014-09-29 09:18:42 INFO otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk boot_disk._check_ovf:350 Checking OVF XML content (could take a few minutes depending on archive size)
 2014-09-29 09:18:42 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk boot_disk._parse_ovf:231 Extracting master/vms/5d5585b3-15bb-4982-a482-67002e4c85cf/5d5585b3-15bb-4982-a482-67002e4c85cf.ovf in /tmp/tmpsxjtIS
 2014-09-29 09:18:42 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk boot_disk._parse_ovf:238 ['master']
 2014-09-29 09:18:42 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk boot_disk._parse_ovf:245 Configuring Disk
 2014-09-29 09:18:42 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk boot_disk._parse_ovf:309 Error parsing OVF file
 Traceback (most recent call last):
  File "/usr/share/ovirt-hosted-engine-setup/plugins/ovirt-hosted-engine-setup/vm/boot_disk.py", line 255, in _parse_ovf
  File "lxml.etree.pyx", line 2272, in lxml.etree._Attrib.__getitem__ (src/lxml/lxml.etree.c:55336)
 KeyError: '{http://schemas.dmtf.org/ovf/envelope/1/}disk-alias'
 2014-09-29 09:18:42 ERROR otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk boot_disk._parse_ovf:311 '{http://schemas.dmtf.org/ovf/envelope/1/}disk-alias'
 2014-09-29 09:18:42 ERROR otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk boot_disk._customization:422 The specified OVF archive is not a valid OVF archive.

Looks like the ovf xml file is not complete. It's at least missing mandatory value: {http://schemas.dmtf.org/ovf/envelope/1/}disk-alias that should exist also if empty.

Please ensure that the OVF you're importing is a rhev-m compatible OVF with a structure like:
              |-- images
              |   |-- <Image Group UUID>
              |        |--- <Image UUID (this is the disk image)>
              |        |--- <Image UUID (this is the disk image)>.meta
              |-- master
              |   |---vms
              |       |--- <UUID>
              |             |--- <UUID>.ovf


and a <UUID>.ovf file confroming to OVF 1 envelope schema:  http://schemas.dmtf.org/ovf/envelope/1/

Comment 4 Fabian Deutsch 2014-09-29 12:14:52 UTC
The OVA is actually created by koji/brew, so no interaction from our side.

Are you using some library to parse the ovf?

Comment 5 Sandro Bonazzola 2014-09-29 12:27:44 UTC
Yes, I use generateDS.py to generate a parser ovfenvelope.py from the OVF schema.

Is koji/brew building a rhev-m compatible OVF? Can you import it inside a running RHEV-M instance without using v2v?

Comment 6 Fabian Deutsch 2014-09-29 12:39:25 UTC
(In reply to Sandro Bonazzola from comment #5)
> Yes, I use generateDS.py to generate a parser ovfenvelope.py from the OVF
> schema.
> 
> Is koji/brew building a rhev-m compatible OVF? Can you import it inside a
> running RHEV-M instance without using v2v?

I'm double checking this, but actually yes - it has two ova formats OS and RHEV - and I'm using the rhev format, i.e.:

Comment 10 wanghui 2014-10-10 10:56:37 UTC
Test version:
rhev-hypervisor7-7.0-20141006.0.el7ev
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm
ovirt-node-plugin-hosted-engine-0.2.0-2.0.el7.x86_64
ovirt-hosted-engine-setup-1.2.1-1.el7.noarch
ovirt-host-deploy-1.3.0-1.el7.noarch
ovirt-hosted-engine-ha-1.2.2-2.el7.noarch

Test steps:
1. Clean install rhev-hypervisor7-7.0-20141006.0.el7ev
2. File ova path in TUI
3. Click <Setup Hosted Engine>

Test result:
1. No such issue now. And vm can be created from OVA file.

So this issue should be fixed in ovirt-hosted-engine-setup-1.2.1-1.el7.noarch.

Thanks!
Hui Wang

Comment 11 Sandro Bonazzola 2014-10-10 13:06:44 UTC
Moving to VERIFIED as per comment #10

Comment 14 errata-xmlrpc 2015-02-11 20:41:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0161.html


Note You need to log in before you can comment on or make changes to this bug.