Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1145728 - change cd fail on 'Drive is not a vdsm image'
Summary: change cd fail on 'Drive is not a vdsm image'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Vitor de Lima
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
: 1149715 (view as bug list)
Depends On:
Blocks: 1073943 rhev35betablocker rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-09-23 14:55 UTC by Ilanit Stein
Modified: 2015-02-17 08:27 UTC (History)
16 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 08:27:42 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
logs (deleted)
2014-09-23 14:56 UTC, Ilanit Stein
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 33471 ovirt-engine-3.5 MERGED core, engine: Fix VM CD change in JSON RPC Never
oVirt gerrit 33472 ovirt-3.5 ABANDONED vm: Fix error with missing cdrom in conf Never
oVirt gerrit 33495 master ABANDONED vm: Fix error with missing cdrom in conf Never
oVirt gerrit 33500 master MERGED core, engine: Fix VM CD change in JSON RPC Never
oVirt gerrit 33501 master MERGED vm: Fix error with missing cdrom in conf Never
oVirt gerrit 34092 ovirt-engine-3.5.0 MERGED core, engine: Fix VM CD change in JSON RPC Never

Description Ilanit Stein 2014-09-23 14:55:09 UTC
Description of problem:
Automatic test with flow: Run once vm with "Start in paused" enabled, and when vm in pause mode, change vm cd, fail for change vm cd.  
http://jenkins-ci.eng.lab.tlv.redhat.com/job/rhevm_3.5_automation_coretools_two_hosts_restapi_vms_nfs_rest_factory/

Version-Release number of selected component (if applicable):
Starting 3.5.0-0.1000.45.3a6d9b8.master.el6ev
and still failing on 3.5.0-0.1000.90.35c6d9e.beta.el6ev (last run)

How reproducible:
100

Additional info:
vdsm.log:
========
Thread-1314::DEBUG::2014-09-22 12:58:40,176::__init__::467::jsonrpc.JsonRpcServer::(_serveRequest) Calling 'VM.changeCD' in bridge with {u'driveSpec': u'/rhev/data-center/mnt/multipass.eng.lab.tlv.redhat.com:_export_images_qa_shared__iso__domain/7233a711-98e8-4c3c-bcfa-44c4bcc4f6c6/images/11111111-1111-1111-1111-111111111111/en_windows_7_enterprise_x64.iso', u'vmID': u'2a12e984-ba1e-47e8-9c2c-bd7910ce8630'}
JsonRpcServer::DEBUG::2014-09-22 12:58:40,176::__init__::504::jsonrpc.JsonRpcServer::(serve_requests) Waiting for request
Thread-1314::INFO::2014-09-22 12:58:40,180::clientIF::331::vds::(prepareVolumePath) prepared volume path: /rhev/data-center/mnt/multipass.eng.lab.tlv.redhat.com:_export_images_qa_shared__iso__domain/7233a711-98e8-4c3c-bcfa-44c4bcc4f6c6/images/11111111-1111-1111-1111-111111111111/en_windows_7_enterprise_x64.iso
Thread-1314::WARNING::2014-09-22 12:58:40,305::clientIF::361::vds::(teardownVolumePath) Drive is not a vdsm image: None
Traceback (most recent call last):
  File "/usr/share/vdsm/clientIF.py", line 354, in teardownVolumePath
    if vm.isVdsmImage(drive):
  File "/usr/share/vdsm/virt/vm.py", line 112, in isVdsmImage
    return all(k in drive for k in required)
  File "/usr/share/vdsm/virt/vm.py", line 112, in <genexpr>
    return all(k in drive for k in required)
TypeError: argument of type 'NoneType' is not iterable
Thread-1314::WARNING::2014-09-22 12:58:40,310::Bridge::210::root::(_typeFixup) Fixing up type VmDevice
Thread-1314::WARNING::2014-09-22 12:58:40,311::Bridge::448::root::(fieldClone) fieldClone: type -> deviceType
. . .

engine.log:
==========
2014-09-22 12:58:40,365 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.ChangeDiskVDSCommand] (ajp-/127.0.0.1:8702-9) [b12ad9e8-38b0-4280_changeCDWhileRunning_update] Failed in ChangeDiskVDS method, for vds: cinteg09.ci.lab.tlv.redhat.com; host: 10.35.148.56
2014-09-22 12:58:40,365 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.ChangeDiskVDSCommand] (ajp-/127.0.0.1:8702-9) [b12ad9e8-38b0-4280_changeCDWhileRunning_update] Command ChangeDiskVDSCommand(HostName = cinteg09.ci.lab.tlv.redhat.com, HostId = 3451c38a-e13c-48c1-adeb-42330002f1bb, vmId=2a12e984-ba1e-47e8-9c2c-bd7910ce8630, diskPath=/rhev/data-center/mnt/multipass.eng.lab.tlv.redhat.com:_export_images_qa_shared__iso__domain/7233a711-98e8-4c3c-bcfa-44c4bcc4f6c6/images/11111111-1111-1111-1111-111111111111/en_windows_7_enterprise_x64.iso) execution failed. Exception: NullPointerException: 
2014-09-22 12:58:40,366 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ChangeDiskVDSCommand] (ajp-/127.0.0.1:8702-9) [b12ad9e8-38b0-4280_changeCDWhileRunning_update] FINISH, ChangeDiskVDSCommand, log id: 6f6cc773
2014-09-22 12:58:40,366 ERROR [org.ovirt.engine.core.bll.ChangeDiskCommand] (ajp-/127.0.0.1:8702-9) [b12ad9e8-38b0-4280_changeCDWhileRunning_update] Command org.ovirt.engine.core.bll.ChangeDiskCommand throw Vdc Bll exception. With error message VdcBLLException: java.lang.NullPointerException (Failed with error ENGINE and code 5001)
2014-09-22 12:58:40,372 ERROR [org.ovirt.engine.core.bll.ChangeDiskCommand] (ajp-/127.0.0.1:8702-9) [b12ad9e8-38b0-4280_changeCDWhileRunning_update] Transaction rolled-back for command: org.ovirt.engine.core.bll.ChangeDiskCommand.
2014-09-22 12:58:40,380 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-9) [b12ad9e8-38b0-4280_changeCDWhileRunning_update] Correlation ID: b12ad9e8-38b0-4280_changeCDWhileRunning_update, Job ID: 6b0d6ca9-b637-4054-9f33-25e4ef223e58, Call Stack: null, Custom Event ID: -1, Message: Failed to change disk in VM run_once_vm (Host: cinteg09.ci.lab.tlv.redhat.com, User: admin).
2014-09-22 12:58:40,385 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp-/127.0.0.1:8702-9) Operation Failed: [Internal Engine Error]

Comment 1 Ilanit Stein 2014-09-23 14:56:13 UTC
Created attachment 940475 [details]
logs

Comment 2 Omer Frenkel 2014-09-24 07:54:13 UTC
might be related to jsonRpc?

Comment 6 Michal Skrivanek 2014-10-02 07:31:29 UTC
note: the vdsm patch is nice to have, but not required for closing the bug

Comment 7 Eyal Edri 2014-10-07 07:13:12 UTC
this bug status was moved to MODIFIED before engine vt5 was built,
hence moving to on_qa, if this was mistake and the fix isn't in,
please contact rhev-integ@redhat.com

Comment 9 Omer Frenkel 2014-10-21 12:20:00 UTC
*** Bug 1149715 has been marked as a duplicate of this bug. ***

Comment 10 Omer Frenkel 2015-02-17 08:27:42 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.