Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1141 - xconsole is not 8 bit clean
Summary: xconsole is not 8 bit clean
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-13 06:12 UTC by Marc MERLIN
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-16 20:53:36 UTC


Attachments (Terms of Use)

Description Marc MERLIN 1999-02-13 06:12:47 UTC
To reproduce: echo "resumi" > /dev/console

This is a problem insofar as I have some syslog messages
are redirected to the console, and my locale is set to
French, so syslog messages get butchered when I see them
in my xconsole.

Comment 1 David Lawrence 1999-03-12 23:10:59 UTC
I was unable to replicate this problem in our test lab.

Comment 2 Marc MERLIN 1999-04-14 06:28:59 UTC
I tried again with starbuck's xconsole, and it's the same.
Here's a simple test case, please try it out:
echo -e 'a\na1i3\nb' > /dev/console
shows:
a
a13
b

note that 1 and 3 are not supposed to touch one another.

In case this should make a difference:
moremagic:~$ echo $LC_ALL
fr_FR
moremagic:~$ echo $LANG
fr

If you tell me this also works for you, I'll drop the case, and assume
something is broken on my side.

Comment 3 Marc MERLIN 1999-06-07 06:16:59 UTC
Ok, I tried again on a straight 6.0 install and the problem is really
there, I'm not sure why dkl wasn't able to reproduce the bug.

I simply did:
- startx (gdm is broken and doesn't chown the console to the user who
  logs in, so xconsole can't work. That's a separate problem though)
- launch xconsole
- echo ripertoire >/dev/console

What shows up on the xconsole is rpertoire...

Comment 4 Jay Turner 1999-06-29 18:10:59 UTC
Confirmed in test lab with XFree86-3.3.3.1-52

Comment 5 Preston Brown 1999-08-16 20:53:59 UTC
This will be fixed in the next release of XFree86.


Note You need to log in before you can comment on or make changes to this bug.