Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1136060 - av11.2 engine failed to create snapshot from rhel-guest-image over couple RHEL7.0 hosts.
Summary: av11.2 engine failed to create snapshot from rhel-guest-image over couple RHE...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.1-1
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Allon Mureinik
QA Contact: Nikolai Sednev
URL:
Whiteboard: storage
Depends On:
Blocks: 1141761 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-09-01 14:41 UTC by Nikolai Sednev
Modified: 2016-02-10 20:24 UTC (History)
15 users (show)

Fixed In Version: vt3
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1141761 (view as bug list)
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:
amureini: needinfo+
amureini: needinfo+


Attachments (Terms of Use)
logs from engine and 2 hosts (deleted)
2014-09-01 14:41 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31271 None None None Never
oVirt gerrit 32239 ovirt-3.4 ABANDONED spec: Require qemu-kvm-rhev in EL Never

Description Nikolai Sednev 2014-09-01 14:41:22 UTC
Created attachment 933459 [details]
logs from engine and 2 hosts

Description of problem:
av11.2 engine failed to create snapshot from rhel-guest-image over couple RHEL7.0 hosts.

Version-Release number of selected component (if applicable):
Linux version 3.10.0-123.6.3.el7.x86_64 (mockbuild@x86-025.build.eng.bos.redhat.com) (gcc version 4.8.2 20140120 (Red Hat 4.8.2-16) (GCC) ) #1 SMP Wed Jul 16 15:10:46 EDT 2014
libvirt-1.1.1-29.el7_0.1.x86_64
vdsm-4.14.13-2.el7ev.x86_64
sanlock-3.1.0-2.el7.x86_64
qemu-kvm-1.5.3-60.el7_0.5.x86_64
Engines version: rhevm-3.4.2-1.1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.Follow TCMS https://tcms.engineering.redhat.com/run/171357/ until snapshot phase. 
2.Try to create snapshot from a VM, while its running and with RAM.

Actual results:
Engine receives error: "	
Failed to complete snapshot '829wmem' creation for VM '829'."

Expected results:
Snapshot should be created without any problems.

Additional info:
logs attached.

Comment 5 Sandro Bonazzola 2014-09-09 12:15:07 UTC
Moving to distribution

Comment 7 Allon Mureinik 2014-09-14 08:00:20 UTC
Note that these are 3.4 hosts (vdsm-4.14.13).
This issue has been resolved in 3.5.0, and should be backported to 3.4.z.

Comment 8 Nikolai Sednev 2014-09-14 14:21:12 UTC
Works for me on these components:
rhevm-3.5.0-0.11.beta.el6ev.noarch
sanlock-3.1.0-2.el7.x86_64
qemu-kvm-rhev-1.5.3-60.el7_0.2.x86_64
vdsm-4.16.4-0.el7.x86_64
libvirt-daemon-1.1.1-29.el7_0.1.x86_64
libvirt-daemon-driver-secret-1.1.1-29.el7_0.1.x86_64
libvirt-daemon-driver-storage-1.1.1-29.el7_0.1.x86_64
libvirt-daemon-driver-qemu-1.1.1-29.el7_0.1.x86_64
libvirt-python-1.1.1-29.el7_0.1.x86_64
libvirt-lock-sanlock-1.1.1-29.el7_0.1.x86_64
libvirt-daemon-kvm-1.1.1-29.el7_0.1.x86_64
libvirt-client-1.1.1-29.el7_0.1.x86_64
libvirt-daemon-driver-interface-1.1.1-29.el7_0.1.x86_64
libvirt-daemon-driver-nodedev-1.1.1-29.el7_0.1.x86_64
libvirt-daemon-config-nwfilter-1.1.1-29.el7_0.1.x86_64
libvirt-daemon-driver-network-1.1.1-29.el7_0.1.x86_64
libvirt-daemon-driver-nwfilter-1.1.1-29.el7_0.1.x86_64

I ran RHEL7.0 guest over RHEL7.0 host and performed live snapshot successfully, then powered off guest-VM and initiated snapshot deletion via engine's WEBUI successfully.

Comment 9 Allon Mureinik 2014-09-14 15:25:49 UTC
Workaround for 3.4.z machines until the fix is backported - manually run "yum install qemu-kvm-rhev qemu-img-rhev"

Comment 12 Gil Klein 2014-09-15 12:07:14 UTC
Moving back to ON_QA, please re-verify with a 3.4.3 build

Comment 15 Allon Mureinik 2014-09-15 12:10:24 UTC
(In reply to Gil Klein from comment #12)
> Moving back to ON_QA, please re-verify with a 3.4.3 build
This should be done on bug 1141761 - /this/ one (for 3.5.0) is verified.

Comment 16 Allon Mureinik 2015-02-16 19:13:47 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 17 Allon Mureinik 2015-02-16 19:13:51 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 18 Nikolai Sednev 2015-02-17 11:25:16 UTC
works for me.


Note You need to log in before you can comment on or make changes to this bug.