Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1136050 - add ppc64le as supported architecture for crash package
Summary: add ppc64le as supported architecture for crash package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: crash
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Anderson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F21AlphaFreezeException F-ExcludeArch-ppc64le, PPC64LETracker F21PPCAlpha
TreeView+ depends on / blocked
 
Reported: 2014-09-01 14:17 UTC by Michel Normand
Modified: 2014-09-23 04:48 UTC (History)
3 users (show)

Fixed In Version: crash-7.0.8-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 04:48:27 UTC


Attachments (Terms of Use)
crash_spec_adding_ppc64le.patch (deleted)
2014-09-01 14:20 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6-add-powerpc64le-linux.patch (deleted)
2014-09-01 14:21 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6-bound_minimal_symbol.patch (deleted)
2014-09-01 14:22 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6-floatformat.patch (deleted)
2014-09-01 14:22 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6-ppc64-ELFv2-trampoline-match.patch (deleted)
2014-09-01 14:23 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6-ppc64_sysv_abi_push_float.patch (deleted)
2014-09-01 14:24 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6-ppc64le.patch (deleted)
2014-09-01 14:25 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6-ppc_insns_match_pattern.patch (deleted)
2014-09-01 14:25 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6-update-autoconf-2013-04-24.patch (deleted)
2014-09-01 14:26 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6-update-autoconf-2013-06-10.patch (deleted)
2014-09-01 14:27 UTC, Michel Normand
no flags Details | Diff
crash-patch-gdb.patch (deleted)
2014-09-01 14:27 UTC, Michel Normand
no flags Details | Diff
crash-gdb-7.6.series (deleted)
2014-09-01 14:31 UTC, Michel Normand
no flags Details

Description Michel Normand 2014-09-01 14:17:57 UTC
Description of problem: 
The last koji build do not support ppc64le: http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=258457
=== spec extract
ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x %{arm} aarch64
===

Version-Release number of selected component (if applicable):
crash-7.0.7-3.fc21

How reproducible:


Steps to Reproduce:
1.fedpkg clone -a crash
2.fedpkg mockbuild

Additional info:
The proposal is to apply the same patches as already applied on opensuse as per url https://build.opensuse.org/package/view_file/openSUSE:Factory:PowerPC/crash/crash-gdb-7.6.series?expand=1

I did a scratch build that succeeded at http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2061121 with next patches in attachment.

Comment 1 Michel Normand 2014-09-01 14:20:28 UTC
Created attachment 933432 [details]
crash_spec_adding_ppc64le.patch

Comment 2 Michel Normand 2014-09-01 14:21:27 UTC
Created attachment 933434 [details]
crash-gdb-7.6-add-powerpc64le-linux.patch

Comment 3 Michel Normand 2014-09-01 14:22:23 UTC
Created attachment 933435 [details]
crash-gdb-7.6-bound_minimal_symbol.patch

Comment 4 Michel Normand 2014-09-01 14:22:57 UTC
Created attachment 933436 [details]
crash-gdb-7.6-floatformat.patch

Comment 5 Michel Normand 2014-09-01 14:23:28 UTC
Created attachment 933437 [details]
crash-gdb-7.6-ppc64-ELFv2-trampoline-match.patch

Comment 6 Michel Normand 2014-09-01 14:24:32 UTC
Created attachment 933438 [details]
crash-gdb-7.6-ppc64_sysv_abi_push_float.patch

Comment 7 Michel Normand 2014-09-01 14:25:08 UTC
Created attachment 933439 [details]
crash-gdb-7.6-ppc64le.patch

Comment 8 Michel Normand 2014-09-01 14:25:44 UTC
Created attachment 933440 [details]
crash-gdb-7.6-ppc_insns_match_pattern.patch

Comment 9 Michel Normand 2014-09-01 14:26:18 UTC
Created attachment 933441 [details]
crash-gdb-7.6-update-autoconf-2013-04-24.patch

Comment 10 Michel Normand 2014-09-01 14:27:18 UTC
Created attachment 933445 [details]
crash-gdb-7.6-update-autoconf-2013-06-10.patch

Comment 11 Michel Normand 2014-09-01 14:27:53 UTC
Created attachment 933446 [details]
crash-patch-gdb.patch

Comment 12 Michel Normand 2014-09-01 14:31:42 UTC
Created attachment 933448 [details]
crash-gdb-7.6.series

Comment 13 Michel Normand 2014-09-10 12:15:05 UTC
Dave, any target date to have those patches integrated in fc21 release ?

Comment 14 Dave Anderson 2014-09-10 12:53:12 UTC
(In reply to Michel Normand from comment #13)
> Dave, any target date to have those patches integrated in fc21 release ?

As soon as the upcoming crash-7.0.8 release is done (by me), I will
then rebase Fedora rawhide.  The patchset is checked into the upstream
git tree:

 https://github.com/crash-utility/crash/commit/f64b1a59541242fa7b2f7d6c50276447e31bcb7d

 Implement support for the ppc64le PPC64 little-endian architecture.
 Since this required a large number of patches to be applied to
 architecture-neutral files in the gdb-7.6 tree, the changes are
 only applied if the host build system is a ppc64le.
 (ptesarik@suse.cz, normand@linux.vnet.ibm.com)

I hope to release crash-7.0.8 later this week, or next week at the
latest.

Comment 15 Gustavo Luiz Duarte 2014-09-10 18:58:11 UTC
Dave, we will need it also for F21, not only Rawhide. Is that possible?

Comment 16 Dave Anderson 2014-09-10 19:15:20 UTC
Has Fedora 21 even been released yet?  I haven't done a build recently,
but if the master/rawhide branch is currently building "fc22" versions,
then I guess it can be merged/pushed back to the f21 branch after that?
Unless there's a F21 freeze until it's officially released.

Comment 17 Mark Hamzy 2014-09-10 19:21:47 UTC
17:09:26,683 WARN packaging: abrt-addon-vmcore-2.2.2-4.fc21.ppc64le requires crash

This blocks anaconda from installing since a repoclosure of the installable set of packages fails to complete.

Comment 18 Gustavo Luiz Duarte 2014-09-10 19:37:18 UTC
Given this blocks the install on ppc64le, I'm proposing it as an F21 Alpha Blocker for PPC and Freeze Exception on primary.

Comment 19 Dave Anderson 2014-09-10 19:58:01 UTC
Just curious -- has anybody looked into kexec-tools?  It probably compiles
OK, but it's going to create an ELF vmcore whose header is marked as MSB.

Comment 20 Gustavo Luiz Duarte 2014-09-10 20:33:36 UTC
(In reply to Dave Anderson from comment #19)
> Just curious -- has anybody looked into kexec-tools?  It probably compiles
> OK, but it's going to create an ELF vmcore whose header is marked as MSB.

F21 has kexec-tools 2.0.7, which should have most of the ppc64le bits. I haven't tried it myself yet as we are focused on getting an installable F21 image out. Once we have an alpha image, we will start testing it more extensively.

Comment 21 Dave Anderson 2014-09-10 20:40:56 UTC
Right -- that's why I was asking.  Looking at the most recent Fedora
sources from kexec-tools-2.0.7-8.fc21, all of the ppc64 files still
only reference ELFDATA2MSB for the ELF header.  For example, in the
"kexec/arch/ppc64/crashdump-ppc64.c" file:

 
static struct crash_elf_info elf_info64 =
{
        class: ELFCLASS64,
        data: ELFDATA2MSB,
        machine: EM_PPC64,
        page_offset: PAGE_OFFSET,
        lowmem_limit: MAXMEM,
};

static struct crash_elf_info elf_info32 =
{
        class: ELFCLASS32,
        data: ELFDATA2MSB,
        machine: EM_PPC64,
        page_offset: PAGE_OFFSET,
        lowmem_limit: MAXMEM,
};

Maybe you've got a side tree with ppc64le bits in it?

Comment 22 Gustavo Luiz Duarte 2014-09-10 20:57:22 UTC
Hmm... you are right, there are still a few patches missing. I will open a bug to track that.

Thanks, Dave!

Comment 23 Michel Normand 2014-09-12 07:45:00 UTC
(In reply to Gustavo Luiz Duarte from comment #22)
> Hmm... you are right, there are still a few patches missing. I will open a
> bug to track that.
> 
> Thanks, Dave!

to avoid confusion while reading this bug #1136050, the comment #19 to comment #22 related to kexec are tracked by a different bug #1140401

Comment 24 Dave Anderson 2014-09-15 19:14:22 UTC
Information for build crash-7.0.8-1.fc22
http://koji.fedoraproject.org/koji/buildinfo?buildID=577451

Comment 25 Dave Anderson 2014-09-15 19:50:24 UTC
Information for build crash-7.0.8-1.fc21
http://koji.fedoraproject.org/koji/buildinfo?buildID=577478

Comment 26 Fedora Update System 2014-09-15 19:54:29 UTC
crash-7.0.8-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/crash-7.0.8-1.fc21

Comment 27 Fedora Update System 2014-09-16 18:44:42 UTC
Package crash-7.0.8-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing crash-7.0.8-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10896/crash-7.0.8-1.fc21
then log in and leave karma (feedback).

Comment 28 Fedora Update System 2014-09-23 04:48:27 UTC
crash-7.0.8-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.