Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1133608 - Change runTime to be set according to Engine DB date and time.
Summary: Change runTime to be set according to Engine DB date and time.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Shirly Radco
QA Contact: Petr Matyáš
URL:
Whiteboard: infra
Depends On: 1152557
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-25 14:45 UTC by Shirly Radco
Modified: 2016-02-10 19:27 UTC (History)
11 users (show)

Fixed In Version: vt10
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1133613 (view as bug list)
Environment:
Last Closed: 2015-02-11 18:16:09 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0177 normal SHIPPED_LIVE rhevm-dwh 3.5 bug fix and enhancement update 2015-02-11 23:11:50 UTC
oVirt gerrit 32240 master MERGED history: updated runTime from engine db Never

Description Shirly Radco 2014-08-25 14:45:04 UTC
Description of problem:
If DWH and Engine are on seperate hosts we must check engine db and history db time is synced.
Otherwise the timestamp of the update date and delete date of the records will be incorect after deletion because they are taken from the current history db time.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Setup DWH and Engine on seperate hosts
2.Set different time for each host
3.Delete an entity and check the changes in the history db

Actual results:
Incurrect timstamp. Create Date is accurding to Engine DB time and Update/Delete Date are accurding to history db time.

Expected results:
Time of Engine and Histiry DBs should be synced.

Additional info:

Comment 1 Shirly Radco 2014-08-25 14:59:46 UTC
I think we should add an hourly check in the etl to test this and send an error if there is a time difference larger than a minute.

Comment 2 Shirly Radco 2014-08-25 15:01:28 UTC
Didi, How can I check that the DWH is on a seperate host?

Comment 3 Yedidyah Bar David 2014-08-26 05:44:15 UTC
(In reply to Shirly Radco from comment #2)
> Didi, How can I check that the DWH is on a seperate host?

In setup code that's easy to check. Not sure that's currently easy to check in dwhd. We can add a config var for that if needed.

Not sure you should check that. There is no harm in checking even if on same host. Adding such a check might needlessly complicate the code. We do that in the setup code only in places where we must - e.g., the minimal etl version check is done only when not on same host, because if on same host, engine and dwh might be upgraded to a newer version by setup, and we do the check prior to this potential upgrade.

Not sure what's the exact behavior, btw - is the "time" we discuss the client's time or the db server time? If db server, then
1. if db servers are different you have the same problem even if apps are on same host
2. therefore, 3.4 is affected too.

Comment 4 Yaniv Lavi 2014-08-26 05:51:44 UTC
Do this test in the service start.
Select from db and compare and fail if they don't match.



Yaniv

Comment 5 Shirly Radco 2014-08-26 07:44:53 UTC
Yaniv,This should be tested hourly in the etl in my opinion and also when we start the etl process. All inside the talend script.
Do you agree?

Comment 6 Yaniv Lavi 2014-08-26 11:10:48 UTC
(In reply to Shirly Radco from comment #5)
> Yaniv,This should be tested hourly in the etl in my opinion and also when we
> start the etl process. All inside the talend script.
> Do you agree?

Why hourly the clock doesn't really change once set.

Comment 7 Barak 2014-08-26 11:43:01 UTC
I agree with Shirly here,
Someone can chenge the time while DWH is running.
And we need to fail the collection with appropriate erreor message.

Comment 8 Barak 2014-08-26 11:43:56 UTC
the check should not be milisecond accurate ....

Comment 9 Shirly Radco 2014-08-31 08:03:48 UTC
We will change so the runTime will be set according to the engine db time.
That way all updates will be according to the same db time.

Comment 12 errata-xmlrpc 2015-02-11 18:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0177.html


Note You need to log in before you can comment on or make changes to this bug.