Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1131965 - [PPC] Vdsm should recognize OSName.POWERKVM
Summary: [PPC] Vdsm should recognize OSName.POWERKVM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: ppc64
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Yaniv Bronhaim
QA Contact: Lukas Svaty
URL:
Whiteboard: infra
: 1140633 (view as bug list)
Depends On:
Blocks: 1122979 rhev3.5beta 1147502 rhev3.5beta3 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-20 12:14 UTC by Dan Kenigsberg
Modified: 2016-02-10 19:03 UTC (History)
13 users (show)

Fixed In Version: vdsm-4.16.7.1-1.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1147502 (view as bug list)
Environment:
Last Closed: 2015-02-16 13:38:58 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32444 master MERGED ppc: Over ppc arch vdsm reports UNKNOWN as operationSystem in getVdsCaps Never
oVirt gerrit 32574 ovirt-3.5 MERGED ppc: Over ppc arch vdsm reports UNKNOWN as operationSystem in getVdsCaps Never
oVirt gerrit 32653 ovirt-3.4 MERGED ppc: Over ppc arch vdsm reports UNKNOWN as operationSystem in getVdsCaps Never
oVirt gerrit 33451 master MERGED Fix typo in filename - ibm_powerkvm-release Never
oVirt gerrit 33452 ovirt-3.5 MERGED Fix typo in filename - ibm_powerkvm-release Never
oVirt gerrit 33473 ovirt-3.4 MERGED Fix typo in filename - ibm_powerkvm-release Never

Description Dan Kenigsberg 2014-08-20 12:14:04 UTC
Description of problem:
Currently Vdsm does not look for /etc/ibm_powerkvm-release and does not find /etc/redhat-release, so it reports operatingSystem='unknown' in getVdsCaps.

Version-Release number of selected component (if applicable):
v4.14.14, v4.16.1

Comment 1 Michal Skrivanek 2014-08-21 06:53:31 UTC
actually it's infra.
Yaniv, would you please take care of it?

Comment 2 Michal Skrivanek 2014-09-02 09:28:44 UTC
actually it turned out it's not a cosmetic change only, there's a specific check for UNKNOWN in API.py preventing any VM to run

Comment 3 Dan Kenigsberg 2014-09-14 15:51:33 UTC
*** Bug 1140633 has been marked as a duplicate of this bug. ***

Comment 4 Dan Kenigsberg 2014-09-26 13:15:35 UTC
/etc/ibm_powerkvm-release is written with a leading underscore, not a hyphen as in the merged patch.

Comment 6 Paz Dangur 2014-10-21 12:27:29 UTC
bug was changed due to a bot error, fixed.

Comment 7 Lukas Svaty 2014-11-10 16:18:56 UTC
verified in vt9


Note You need to log in before you can comment on or make changes to this bug.