Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1131944 - Connection refused when trying to activate host
Summary: Connection refused when trying to activate host
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Piotr Kliczewski
QA Contact: Petr Kubica
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-20 11:20 UTC by Ohad Basan
Modified: 2016-02-10 19:36 UTC (History)
10 users (show)

Fixed In Version: vt2.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:07:43 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31427 master MERGED jsonrpc: Version update Never
oVirt gerrit 31570 master MERGED Make sure that connection is closed when refused Never
oVirt gerrit 31981 ovirt-engine-3.5 MERGED core: setting default protocol to jsonrpc again Never
oVirt gerrit 32109 ovirt-engine-3.5 MERGED jsonrpc: Version update Never

Description Ohad Basan 2014-08-20 11:20:01 UTC
Description of problem:
after host deploy vdsm is running successfully but the engine fails to communicate it
therefore the host activation command fails
the test is done on rhel6
2014-08-15 22:59:22,973 ERROR [org.ovirt.vdsm.jsonrpc.client.reactors.ReactorClient] (org.ovirt.thread.pool-6-thread-9) Exception during connection: java.util.concurrent.ExecutionException: java.net.ConnectException: Connection refused
	at java.util.concurrent.FutureTask.report(FutureTask.java:122) [rt.jar:1.7.0_65]
	at java.util.concurrent.FutureTask.get(FutureTask.java:188) [rt.jar:1.7.0_65]
	at org.ovirt.vdsm.jsonrpc.client.reactors.ReactorClient.connect(ReactorClient.java:94) [vdsm-jsonrpc-java-client.jar:]
	at org.ovirt.vdsm.jsonrpc.client.JsonRpcClient.getClient(JsonRpcClient.java:98) [vdsm-jsonrpc-java-client.jar:]
	at org.ovirt.vdsm.jsonrpc.client.JsonRpcClient.call(JsonRpcClient.java:56) [vdsm-jsonrpc-java-client.jar:]
	at org.ovirt.engine.core.vdsbroker.jsonrpc.FutureMap.<init>(FutureMap.java:57) [vdsbroker.jar:]
	at org.ovirt.engine.core.vdsbroker.jsonrpc.JsonRpcVdsServer$2.call(JsonRpcVdsServer.java:871) [vdsbroker.jar:]
	at org.ovirt.engine.core.vdsbroker.jsonrpc.JsonRpcVdsServer$2.call(JsonRpcVdsServer.java:867) [vdsbroker.jar:]
	at java.util.concurrent.FutureTask.run(FutureTask.java:262) [rt.jar:1.7.0_65]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_65]
	at java.util.concurrent.FutureTask.run(FutureTask.java:262) [rt.jar:1.7.0_65]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_65]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_65]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_65]
Caused by: java.net.ConnectException: Connection refused
	at sun.nio.ch.Net.connect0(Native Method) [rt.jar:1.7.0_65]
	at sun.nio.ch.Net.connect(Net.java:465) [rt.jar:1.7.0_65]
	at sun.nio.ch.Net.connect(Net.java:457) [rt.jar:1.7.0_65]
	at sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:670) [rt.jar:1.7.0_65]
	at org.ovirt.vdsm.jsonrpc.client.reactors.ReactorClient$1.call(ReactorClient.java:87) [vdsm-jsonrpc-java-client.jar:]
	at org.ovirt.vdsm.jsonrpc.client.reactors.ReactorClient$1.call(ReactorClient.java:77) [vdsm-jsonrpc-java-client.jar:]
	at org.ovirt.vdsm.jsonrpc.client.utils.retry.Retryable.call(Retryable.java:26) [vdsm-jsonrpc-java-client.jar:]
	at java.util.concurrent.FutureTask.run(FutureTask.java:262) [rt.jar:1.7.0_65]
	at org.ovirt.vdsm.jsonrpc.client.utils.ReactorScheduler.performPendingOperations(ReactorScheduler.java:28) [vdsm-jsonrpc-java-client.jar:]
	at org.ovirt.vdsm.jsonrpc.client.reactors.Reactor.run(Reactor.java:57) [vdsm-jsonrpc-java-client.jar:]

Comment 4 Petr Kubica 2014-09-22 10:07:28 UTC
verified in:
engine:
rhevm: 3.5.0-0.12.beta.el6ev
vdsm-jsonrpc-java-1.0.6-1.el6ev.noarch
host:
vdsm-4.16.3-3.el6ev.beta.x86_64

Comment 6 Eyal Edri 2015-02-17 17:07:43 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.