Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1130791 - [REGRESSION] Power management TEST button fails always in 3.4 DC/Cluster
Summary: [REGRESSION] Power management TEST button fails always in 3.4 DC/Cluster
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Eli Mesika
QA Contact: sefi litmanovich
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-17 19:20 UTC by Eli Mesika
Modified: 2016-02-10 19:31 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:08:54 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31575 master MERGED core: fix fence-status operation Never
oVirt gerrit 31603 ovirt-engine-3.5 MERGED core: fix fence-status operation Never

Description Eli Mesika 2014-08-17 19:20:17 UTC
Description of problem:

Power management TEST button fails always in 3.4 DC/Cluster

Commit 52bee82409eee65ef22af805b21113afa1b76a03 adds Fencing Policy support.
One of the changes was in FenceExecutor:isAgentSupported 

code added that cause the problem :

--start--
ret = ret && _vds.getSupportedClusterVersionsSet().contains(minVersionSupportingFencingPol);
--end--

The second value in the && operator is constantly false when doing a TEST from UI (this actually calls GetNewVdsFenceStatusQuery)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Define 2 hosts in a 3.4 cluster 
2.Add valid PM settings to one of teh Hosts
3.Click the TEST button

Actual results:
TEST fails with a message that no proxy host found in the Cluster/DC

Expected results:
TEST should succeed 

Additional info:

Comment 1 Martin Perina 2014-08-18 10:35:55 UTC
The problem is, that VDS instance passed to FenceExecutor is not properly filled,
only PM options are present, but cluster level compatibility needed for fencing policy check is null. Since fencing policy is used only for VdsNonRespondingTreatment, best solution will be to check fencing policy only when it's present.

Comment 2 sefi litmanovich 2014-09-16 10:37:17 UTC
Verified with rhevm-3.5.0-0.12.beta.el6ev.noarch according to use case in the description.

Comment 3 Eyal Edri 2015-02-17 17:08:54 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.