Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1130182 - Missing 'disks' link when listing vm entities for export storage domains
Summary: Missing 'disks' link when listing vm entities for export storage domains
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Daniel Erez
QA Contact: Carlos Mestre González
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-14 13:55 UTC by Carlos Mestre González
Modified: 2016-02-10 19:04 UTC (History)
12 users (show)

Fixed In Version: vt2.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31553 master MERGED restapi: missing disks link in SD VMs resource Never
oVirt gerrit 31918 ovirt-engine-3.5 MERGED restapi: missing disks link in SD VMs resource Never

Description Carlos Mestre González 2014-08-14 13:55:19 UTC
Description of problem:
GET for /api/storagedomains/{storagedomain:id}/vms/ returns vms entities without disks' link.

The link is returned only when accessing the {vm:id} object. This doesn't correspond with the behaviour for other collections (/api/vms/ or /api/templates/) where all the links elements are returned per entity.

Version-Release number of selected component (if applicable):
rhevm-3.4.2-0.1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Export a few vm's with disks
2. rest-api call for GET /api/storagedomains/{storagedomain:id}/vms/

Actual results:
list of vm are returned but without the disks' link (is there for /api/storagedomains/{storagedomain:id}/vms/{vm:id})

Expected results:
for each vm entity there's a link to the vm disks' collection

Additional info:
Related: https://bugzilla.redhat.com/show_bug.cgi?id=1117747

Adding a new bug since BZ1117747 was a regression.

Comment 2 Carlos Mestre González 2014-09-16 08:53:05 UTC
Verified in vt3.1.

Comment 3 Allon Mureinik 2015-02-16 19:12:38 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 4 Allon Mureinik 2015-02-16 19:12:38 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.