Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1130065 - GetAllDisksByVmId - NPE when vm is being removed
Summary: GetAllDisksByVmId - NPE when vm is being removed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Liron Aravot
QA Contact: Elad
URL:
Whiteboard: storage
: 1219342 (view as bug list)
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-14 09:08 UTC by Liron Aravot
Modified: 2016-02-10 19:05 UTC (History)
14 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1129258
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 22506 master MERGED core: GetAllDisksByVmIdQuery - improved performance Never
oVirt gerrit 31498 master MERGED core: GetAllDisksByVmId - race condition leads to NPE Never
oVirt gerrit 31554 ovirt-engine-3.5 MERGED core: GetAllDisksByVmId - race condition leads to NPE Never

Description Liron Aravot 2014-08-14 09:08:03 UTC
+++ This bug was initially created as a clone of Bug #1129258 +++

Description of problem:
oVirt allows the admin to pack domains until there is 0 free space left,
this behavior is not healthy to the whole system and leads to multiple ERROR's
and NullPointerException's.

for example packing a block domain with add template command while removing vm with disks on the same domain fails with  NPE.

Version-Release number of selected component (if applicable):
rc1

How reproducible:
?

Steps to Reproduce:
1.remove a vm with disks while being over the disks subtab

Actual results:
 NPE will be logged

Expected results:
NPE shouldn't occur

Additional info:

Comment 1 Allon Mureinik 2014-08-14 10:34:27 UTC
Liron, please add steps to reproduce.

Comment 2 Elad 2014-08-26 12:17:22 UTC
Liron, we need steps to reproduce

Comment 3 Liron Aravot 2014-08-26 12:37:03 UTC
remove a vm with disks while being over the disks subtab leading to refresh.

Comment 4 Elad 2014-08-27 08:55:15 UTC
Removed a VM with more than 10 disks attached while being over the disks sub-tab. VM was removed successfully and no NPE appeared in engine.log.
Tested ~5 times.

Tested against rhev3.4.2 av11.1 where the bug is reproduced (50% reproducible)

Verified using ovirt-3.5-RC1.1

Comment 5 Allon Mureinik 2015-02-16 19:12:53 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 6 Allon Mureinik 2015-02-16 19:12:54 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 7 Tal Nisan 2015-05-10 10:53:01 UTC
*** Bug 1219342 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.