Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1128839 - [log-collector] no engine.log in the final archive
Summary: [log-collector] no engine.log in the final archive
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On: 1123808
Blocks: 1129373 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-11 15:38 UTC by Sandro Bonazzola
Modified: 2015-02-11 17:46 UTC (History)
14 users (show)

Fixed In Version: rhevm-log-collector-3.5.0-0.2.master.el6_5
Doc Type: Bug Fix
Doc Text:
A bug in RHEV-M sos plugin shipped with the engine-log-collector package caused the engine.log to be missing from the archive generated by the engine-log-collector. This bug fix updates the plug-in and the engine.log file is now included in the generated reports.
Clone Of: 1123808
: 1129373 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:46:25 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0193 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2015-02-11 22:35:42 UTC
oVirt gerrit 30788 None None None Never
oVirt gerrit 30789 None None None Never
oVirt gerrit 31349 ovirt-log-collector-3.4 MERGED sos2: fix callExtProg usage Never
oVirt gerrit 31357 master MERGED sos: fixing backport issues Never
oVirt gerrit 31415 ovirt-log-collector-3.5 MERGED sos: fixing backport issues Never
oVirt gerrit 31416 ovirt-log-collector-3.4 MERGED sos: fixing backport issues Never

Description Sandro Bonazzola 2014-08-11 15:38:32 UTC
The bug was already fixed in upstream 3.5, it affects also downstream rhevm-log-collector 3.4.4 targeted to rhevm-3.4.2.

+++ This bug was initially created as a clone of Bug #1123808 +++

Description of problem:

$ tar tJf /tmp/sosreport-LogCollector-20140728114608.tar.xz | grep engine
./jb-ovirt35-2014072811391406540390/etc/httpd/conf.d/z-ovirt-engine-proxy.conf
./jb-ovirt35-2014072811391406540390/etc/httpd/conf.d/ovirt-engine-root-redirect.conf
./jb-ovirt35-2014072811391406540390/etc/selinux/targeted/modules/active/modules/cfengine.pp

where is engine.log and its friends?

# find /var/log/ovirt-engine/ -type f | wc -l
17

Version-Release number of selected component (if applicable):
ovirt-log-collector-3.5.0-0.1.master.20140715.gitf738f97.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. engine-log-collector
2.
3.

Actual results:
archive does not contain important log files

Expected results:
should be there

Additional info:
2014-07-28 11:39:45::INFO::engine-log-collector::1340::root:: Gathering oVirt Engine information...
2014-07-28 11:40:57::INFO::engine-log-collector::1314::root:: Gathering PostgreSQL the oVirt Engine database and log files from localhost...
2014-07-28 11:45:17::INFO::engine-log-collector::1267::root:: Gathering information from selected hypervisors...
2014-07-28 11:45:17::INFO::engine-log-collector::709::root:: collecting information from 10.34.63.222
2014-07-28 11:46:08::INFO::engine-log-collector::767::root:: finished collecting information from 10.34.63.222
2014-07-28 11:46:32::INFO::engine-log-collector::1708::root:: Log files have been collected and placed in /tmp/sosreport-LogCollector-20140728114608.tar.xz.
The MD5 for this file is ea7c1da168dc18a0b6fb143ffda8c447 and its size is 100.8M

--- Additional comment from Jiri Belka on 2014-07-28 06:02:24 EDT ---

Maybe there should be a check if it really collects anything useful :)

--- Additional comment from Sandro Bonazzola on 2014-07-29 07:50:35 EDT ---

This affects EL6 only and it's due to an error while back-porting sos3 plugin to sos2 API.

The traceback is:
 Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/sos/sosreport.py", line 729, in  sosreport
    plug.setup()
  File "/usr/lib/python2.6/site-packages/sos/plugins/ovirt.py", line 71, in setup
    lines = self.callExtProg(pgrep)['output'].splitlines()
 TypeError: tuple indices must be integers, not str

A patch will follow in a few minutes.

--- Additional comment from Jiri Belka on 2014-08-06 10:43:56 EDT ---

ovirt-3.5.0_rc1 has latest ovirt-log-collector-3.5.0-0.1.master.el6.noarch which is from Wed 23 Jul 2014 01:09:43 PM CEST and does not contain the fix.

please provide new build and version. thx.

--- Additional comment from Sandro Bonazzola on 2014-08-08 05:09:11 EDT ---

There was an issue in oVirt jenkins[1], missing to add timestamp suffix to the built rpm. The ovirt-3.5-pre repository has now been updated with the right rpm (same rpm version and release due to jenkins issue) and should contain the fix. 

We're fixing the timestamp suffix issue so next rc shouldn't be affected

[1] https://fedorahosted.org/ovirt/ticket/231

--- Additional comment from Jiri Belka on 2014-08-08 08:23:45 EDT ---

ok now.

# tar tJf /tmp/sosreport-LogCollector-20140808141859.tar.xz | grep /var/log/ovirt-engine/
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/setup/
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/setup/ovirt-engine-setup-20140806113324-g6roac.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/setup/ovirt-engine-setup-20140722135804-1g2znn.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/engine.log-20140805.gz
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/engine.log-20140731.gz
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/console.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/engine.log-20140803.gz
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/ovirt-log-collector/
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/ovirt-log-collector/ovirt-log-collector-20140806162138.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/ovirt-log-collector/ovirt-log-collector-20140808141416.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/engine.log-20140802.gz
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/engine.log-20140808.gz
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/engine.log-20140804.gz
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/engine.log-20140806.gz
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/host-deploy/
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/host-deploy/ovirt-20140730150712-10.34.63.222-7278626f.log-20140801.gz
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/host-deploy/ovirt-20140808130529-10.34.63.223-513d8b3d.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/host-deploy/ovirt-20140805170012-10.34.62.205-535c8a1b.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/boot.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/engine.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/server.log
./jb-ovirt35-2014080814141407500063/var/log/ovirt-engine/engine.log-20140801.gz

# rpm -qi ovirt-log-collector | grep 'Build Date'
Release     : 0.1.master.el6                Build Date: Tue 29 Jul 2014 01:57:53 PM CEST

Comment 3 Petr Beňas 2014-08-27 11:33:25 UTC
in ovirt-log-collector-3.5.0-0.1.master.20140813134850.gitfb987b4.el6.noarch

Comment 6 errata-xmlrpc 2015-02-11 17:46:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0193.html


Note You need to log in before you can comment on or make changes to this bug.