Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1128761 - can't add host: NoSuchMethodError
Summary: can't add host: NoSuchMethodError
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
: 1128778 (view as bug list)
Depends On:
Blocks: 1110831 1115466 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-11 13:48 UTC by Ohad Basan
Modified: 2015-02-12 14:10 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-12 14:10:35 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31341 master MERGED packaging: spec: require latest vdsm-jsonrpc-java Never
oVirt gerrit 31376 ovirt-engine-3.5 MERGED packaging: spec: require latest vdsm-jsonrpc-java Never

Description Ohad Basan 2014-08-11 13:48:20 UTC
Description of problem:

Caused by: java.lang.NoSuchMethodError: org.ovirt.vdsm.jsonrpc.client.utils.retry.RetryPolicy.<init>(IIILjava/lang/Class;)V
appears in the engine logs when installing a host

I think it's caused by the following patch
http://gerrit.ovirt.org/#/c/31229/

Comment 1 Sandro Bonazzola 2014-08-11 14:10:43 UTC
Looks like we need to require latest version of vdsm-jsonrpc-java

Comment 2 Oved Ourfali 2014-08-12 10:52:41 UTC
*** Bug 1128778 has been marked as a duplicate of this bug. ***

Comment 3 Petr Beňas 2014-08-26 13:23:40 UTC
Successfully added host with vdsm-4.16.2-1.gite8cba75.el6.x86_64 to  oVirt Engine Version: 3.5.0-0.0.master.20140821064931.gitb794d66.el6


Note You need to log in before you can comment on or make changes to this bug.