Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1128738 - /etc/rhevm is not collected
Summary: /etc/rhevm is not collected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On: 1128830
Blocks: 1129698 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-11 12:55 UTC by Petr Beňas
Modified: 2015-02-11 17:46 UTC (History)
14 users (show)

Fixed In Version: rhevm-log-collector-3.5.0-0.2.master.el6_5
Doc Type: Bug Fix
Doc Text:
Some RHEV-M configuration content was not collected and caused the incompleteness of the SOS report collection. engine-log-collector was updated to collect the content of the /etc/rhevm file.
Clone Of:
: 1129698 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:46:20 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0193 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2015-02-11 22:35:42 UTC
oVirt gerrit 31379 master MERGED sos: collect /etc/rhevm Never
oVirt gerrit 31417 ovirt-log-collector-3.5 MERGED sos: collect /etc/rhevm Never

Description Petr Beňas 2014-08-11 12:55:05 UTC
Description of problem:
rhevm configs are not collected

Version-Release number of selected component (if applicable):
ovirt-log-collector-3.4.4

How reproducible:
100%

Steps to Reproduce:
1. log collector collect
2. unpack
3. check the engine/etc direcotry 

Actual results:
no rhevm directory

Expected results:
rhevm or ovirt-engine directory

Additional info:

Comment 1 Petr Beňas 2014-08-11 14:30:54 UTC
Seems to affect 3.5 as well.

Comment 2 Sandro Bonazzola 2014-08-11 15:32:22 UTC
(In reply to Petr Beňas from comment #1)
> Seems to affect 3.5 as well.

It's a bug in sos. I can workaround it duplicating the directory content instead of creating the symlink in the archive. Is this acceptable for the automation testing? Or does it require the symlink?

From a GSS point of view, is this relevant? Do we really need the symlink?

While testing this, I've found some issues. I'll open a bug for them.

Comment 3 Tomas Dosek 2014-08-12 06:29:24 UTC
From our point of view it's necessary to have the folder content in sos. It's not really matter to us how the implementation would look.

Comment 4 Yedidyah Bar David 2014-08-12 06:37:45 UTC
(In reply to Tomas Dosek from comment #3)
> From our point of view it's necessary to have the folder content in sos.
> It's not really matter to us how the implementation would look.

Just to clarify Sandro's question: For some versions now, /etc/rhevm is a symlink to /etc/ovirt-engine. We already collect the latter. The question was whether it's important at all to also collect /etc/rhevm (which, as Sandro said, with the current implementation will look like a copy of /etc/ovirt-engine rather than a symlink to it).

Comment 5 Yedidyah Bar David 2014-08-12 06:39:51 UTC
Sandro - on a second thought, I think we do have to collect also /etc/rhevm, just for weird cases where it does not exist (although iirc this shouldn't break anything) or where it's actually not a symlink but a partial/modified copy of /etc/ovirt-engine.

Comment 6 Sandro Bonazzola 2014-08-12 06:54:56 UTC
(In reply to Yedidyah Bar David from comment #5)
> Sandro - on a second thought, I think we do have to collect also /etc/rhevm,
> just for weird cases where it does not exist (although iirc this shouldn't
> break anything) or where it's actually not a symlink but a partial/modified
> copy of /etc/ovirt-engine.

Ok, make sense.

Comment 7 Oved Ourfali 2014-08-12 10:42:21 UTC
Why is this bug on POST without setting a proper group in the whiteboard?

Comment 8 Sandro Bonazzola 2014-08-12 11:31:16 UTC
(In reply to Oved Ourfali from comment #7)
> Why is this bug on POST without setting a proper group in the whiteboard?

Just forgot to set the field, sorry.

Comment 11 Petr Beňas 2014-08-27 11:34:09 UTC
in ovirt-log-collector-3.5.0-0.1.master.20140813134850.gitfb987b4.el6.noarch

Comment 15 errata-xmlrpc 2015-02-11 17:46:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0193.html


Note You need to log in before you can comment on or make changes to this bug.