Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 112867 - ATI proprietary drivers not working on some 2.6 kernels
Summary: ATI proprietary drivers not working on some 2.6 kernels
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 1
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-04 21:15 UTC by Bernie Innocenti
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:33 UTC


Attachments (Terms of Use)

Description Bernie Innocenti 2004-01-04 21:15:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux 2.6.0-1.23custom; X11; , en) (KHTML, like Gecko)

Description of problem:
The kernel module fglrx.ko compiled from
fglrx-glc22-4.3.0-3.7.0.i386.rpm (available from ATI)
works fine with these kernels:

  2.6.0-1.103 (Arjan)
  2.6.0-1.23 (Fedora)

insmodding in 2.6.0-1.109 produces a OOPS for NULL
pointer dereference (sorry, can't provide more detail
right now).

My guess is that it has something to do with changes in
include/linux or include/asm-i386, because I've seen the
very same OOPS in -1.23 using fglrx.ko built with the
-1.109 headers.


Version-Release number of selected component (if applicable):
kernel-2.6.0-1.109

How reproducible:
Always

Steps to Reproduce:
1. build and install kernel-source-2.6.0-1.109
2. download and install fglrx-glc22-4.3.0-3.7.0.i386.rpm
3. build module in /lib/modules/fglrx/build_mod/2.6.x
4. install module
5. insmod fglrx


Additional info:

Comment 1 Arjan van de Ven 2004-01-04 21:55:01 UTC
I'm sorry but I don't care if binary only modules can be linked in the
kernel or not.

*** This bug has been marked as a duplicate of 78616 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:33 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.