Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1127640 - Report UI error when check the vdsm-plugin rpm/srpm/file diff
Summary: Report UI error when check the vdsm-plugin rpm/srpm/file diff
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: rebase-ovirt-node-3.1
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-07 09:41 UTC by wanghui
Modified: 2016-02-10 20:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:00:56 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 31183 master MERGED core: Fix logger typo Never

Description wanghui 2014-08-07 09:41:57 UTC
Description of problem:
It reports as follows when check the vdsm-plugin rpm/srpm/file diff button.
================================================================================
An error appeared in the UI: AttributeError("'Plugin' object has no attribute 'logged'",)
Press ENTER to logout...
or enter 's' to drop to shell
================================================================================

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140806.1.iso
ovirt-node-3.1.0-0.7.20140806gitef5c5cb.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. TUI install rhev-hypervisor7-7.0-20140806.1.iso
2. Check the plugins page with press rpm/srpm/file diff button

Actual results:
1. It reports as follows when check the vdsm-plugin rpm/srpm/file diff button.
================================================================================
An error appeared in the UI: AttributeError("'Plugin' object has no attribute 'logged'",)
Press ENTER to logout...
or enter 's' to drop to shell
================================================================================

Expected results:
1. It should show diff info without error.

Additional info:

Comment 2 wanghui 2014-10-13 05:56:10 UTC
Test version:
rhev-hypervisor7-7.0-20141006.0.el7ev
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm

Test step:
1. TUI install rhev-hypervisor7-7.0-20140806.1.iso
2. Check the plugins page with press rpm/srpm/file diff button

Test result:
1. It shows as follows without UI error occured.
   An Error Occured
   No manifest found.

According to comment#6 in bug#1039233 , this issue should be fixed as the error warning shows.Change the status from ON_QA to VERIFIED.

Comment 4 errata-xmlrpc 2015-02-11 21:00:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.