Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1127201 - edit-node:Thrown NameError: global name 'options' is not defined in in _cleanup_editing
Summary: edit-node:Thrown NameError: global name 'options' is not defined in in _clean...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: rebase-ovirt-node-3.1
Blocks: rhevh-7.0 rhev3.5beta rhev35betablocker 1156165 rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-08-06 11:36 UTC by haiyang,dong
Modified: 2016-02-10 20:09 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:00:46 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 31138 master MERGED edit-node: fix global name 'options' is not defined issue Never

Description haiyang,dong 2014-08-06 11:36:09 UTC
Description of problem:
Thrown NameError: global name 'options' is not defined in  in _cleanup_editing:
[root@dhcp-8-228 edit-node]# edit-node --repo=edit-node.repo --install=ovirt-node-plugin-ipmi-3.1.0-0.7.20140806gitef5c5cb.el7.noarch.rpm rhev-hypervisor7-7.0-20140714.0.iso 
rhev-hypervisor7-7.0-20140714.0.iso
Warning: the state of SELinux is disabled
Installing Packages
Setting Up DNS For Chroot
Configuring Yum Repo
WARNING: rpm directory /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6 does not exist
Running Yum Install
['ovirt-node-plugin-ipmi-3.1.0-0.7.20140806gitef5c5cb.el7.noarch.rpm']
Examining /tmp/yumrepo/ovirt-node-plugin-ipmi-3.1.0-0.7.20140806gitef5c5cb.el7.noarch.rpm: ovirt-node-plugin-ipmi-3.1.0-0.7.20140806gitef5c5cb.el7.noarch
Marking /tmp/yumrepo/ovirt-node-plugin-ipmi-3.1.0-0.7.20140806gitef5c5cb.el7.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
.....
Complete!

Cleaning Up Yum Configuration
Traceback (most recent call last):
  File "/usr/sbin/edit-node", line 1753, in <module>
    sys.exit(main())
  File "/usr/sbin/edit-node", line 1558, in main
    if not editor._install_pkgs(options):
  File "/usr/sbin/edit-node", line 903, in _install_pkgs
    self._cleanup_editing()
  File "/usr/sbin/edit-node", line 1128, in _cleanup_editing
    if self.item and os.path.exists(options.repo):
NameError: global name 'options' is not defined


Version-Release number of selected component (if applicable):
ovirt-node-tools-3.1.0-0.7.20140806gitef5c5cb.el7.noarch.rpm
ovirt-node-minimizer-3.1.0-0.7.20140806gitef5c5cb.el7.noarch.rpm

How reproducible:
100%


Steps to Reproduce:


Actual results:

Expected results:

Comment 4 haiyang,dong 2014-10-08 10:55:13 UTC
This bug has been fixed in the follow version:
rhev-hypervisor7-7.0-20141006.0.el7ev.noarch
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch
ovirt-node-tools-3.1.0-0.20.20141006gitc421e04.el7.noarch

so change the status into "VERIFIED".

Comment 7 errata-xmlrpc 2015-02-11 21:00:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.