Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1126782 - failue on SetVolumeDescription shouldn't trigger spm failover
Summary: failue on SetVolumeDescription shouldn't trigger spm failover
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Liron Aravot
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-05 09:28 UTC by Liron Aravot
Modified: 2016-05-26 01:48 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31014 master MERGED core: avoid failover on setVolumeDescription default fail Never
oVirt gerrit 31565 ovirt-engine-3.5 MERGED core: avoid failover on setVolumeDescription default fail Never

Description Liron Aravot 2014-08-05 09:28:39 UTC
Description of problem:
When failing to change the volume description, the spm failover shouldn't be triggered automatically.

How reproducible:
Always

Steps to Reproduce:
1. have a data center on version 3.5 and up, two hosts (hsm and spm).
1. Update a vm with a image disk on the datacenter from 1.
2. ovf update should run after X minutes (to shorten the time you can reduce the 'OvfUpdateIntervalInMinutes' config value
3. the first step of the ovf update is to set the volume description to the ovf disk, trigger failure on that and verify that no failover occurs (verify that the error is of the ones that otherwise would trigger spm failover).

Actual results:
spm failover is triggered.

Expected results:
spm failover isn't triggered.

Comment 1 Ori Gofen 2014-09-09 06:55:34 UTC
This bug obviously should be verified using webadmin portal,rest-api operation
and those are just not supported yet due to BZ #1047621

Comment 2 Liron Aravot 2014-09-09 07:19:53 UTC
Ori, please take a look on the reprorducation steps i've added. the ovf stores update is using that call.

Comment 3 Ori Gofen 2014-09-09 08:22:12 UTC
I Have,you are right about the dependency part

Comment 4 Ori Gofen 2014-09-15 08:53:31 UTC
verified on vt3.1 steps taken:

1) initiated a volume corruption to OvfStoreFile
2) waited for SetVolumeDescriptionVDSCommand to fail:

2014-09-15 11:49:41,523 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (DefaultQuartzScheduler_Worker-29) [1aab8938] Failed in SetVolumeDescriptionVDS method
2014-09-15 11:49:41,523 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (DefaultQuartzScheduler_Worker-29) [1aab8938] Command SetVolumeDescriptionVDSCommand( storagePoolId = 00000002-0002-0002-0002-000000000045, ignoreFailoverLimit = false, storageDomainId = d29a83db-d22b-454f-8707-4bc461192dc1, imageGroupId = 7b5a08b1-fea1-4f9e-9522-16ee73e7878f, imageId = d1259c58-b80a-4fa8-a882-1c3ba706fc2d) execution failed. Exception: IrsOperationFailedNoFailoverException: IRSGenericException: IRSErrorException: Failed to SetVolumeDescriptionVDS, error = Volume does not exist: ('d1259c58-b80a-4fa8-a882-1c3ba706fc2d',), code = 201

3) no SPM failure was noted

Comment 5 Allon Mureinik 2015-02-16 19:11:55 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 6 Allon Mureinik 2015-02-16 19:11:56 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.