Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1126204 - placeholders of child commands aren't cleared when failing during the execution
Summary: placeholders of child commands aren't cleared when failing during the execution
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Ravi Nori
QA Contact: Jiri Belka
URL:
Whiteboard: infra
: 1126205 (view as bug list)
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-08-03 14:39 UTC by Liron Aravot
Modified: 2016-02-10 19:20 UTC (History)
16 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1126205 (view as bug list)
Environment:
Last Closed: 2015-02-17 17:13:46 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
logs + table data (deleted)
2014-08-03 14:39 UTC, Liron Aravot
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31037 master MERGED engine : placeholders of child commands aren't cleared on exception Never
oVirt gerrit 31352 ovirt-engine-3.5 MERGED engine : placeholders of child commands aren't cleared on exception Never

Description Liron Aravot 2014-08-03 14:39:19 UTC
Created attachment 923633 [details]
logs + table data

Description of problem:
Task placeholders aren't being cleared on failure to execute a command

How reproducible:
Always

Steps to Reproduce:
1. Execute a command which creates async task placeholders for it's child commands  when more than one child commands is supposed to be executed (for example - AddVmTemplate for vm with more than one disk)
2. Fail during the execution of one of it's child commands 

Actual results:
The placeholder for the failed child command will be cleared, the other child command placeholders aren't cleared.

Expected results:
All placeholders should be cleared

Comment 1 Ravi Nori 2014-08-04 17:12:55 UTC
*** Bug 1126205 has been marked as a duplicate of this bug. ***

Comment 2 Jiri Belka 2014-09-05 14:15:30 UTC
please provide exact steps for verification, thank you

Comment 3 Ravi Nori 2014-09-05 14:19:29 UTC
I manually threw an exception in the execution of one of the child commands. Adding need info on Liron Aravot for ideas how to test this. I would consider this a code change.

Comment 4 Liron Aravot 2014-09-10 08:17:58 UTC
We can manually cause to exception in the execute phase, for example, move image folder in the storage manually which will cause to an error when trying to copy it.

Comment 5 Jiri Belka 2014-09-11 10:01:14 UTC
ok, rhevm-backend-3.5.0-0.11.beta.el6ev.noarch

tested while creating a vm from template and the template's disk dir on storage domain was renamed, no async task after failure.

Comment 6 Eyal Edri 2015-02-17 17:13:46 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.