Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1125982 - "Configuration" tab should be available for an organization only in case of Provisioning entitlements are provided.
Summary: "Configuration" tab should be available for an organization only in case of P...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 560
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-08-01 14:19 UTC by Dimitar Yordanov
Modified: 2016-02-03 19:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-03 19:57:29 UTC


Attachments (Terms of Use)

Description Dimitar Yordanov 2014-08-01 14:19:23 UTC
Description of problem:
"Configuration" tab should be available for an organization only in case  Provisioning entitlements are provided.

Version-Release number of selected component (if applicable):
spacewalk-java-2.0.2-79

How reproducible:
100%

Steps to Reproduce:
1. Create new Organization "test_org".
2. Login to "test_org".
    Notice that "Configuration" tab is not available. 
3. Set 1 Provisioning entitlement to "test_org". 
4. Notice that "Configuration" tab is now available. 
5. Set Provisioning entitlement count again back to 0 for "test_org". 

Actual results:
"Configuration" tab is available. 

Expected results:
"Configuration" tab is not available when Provisioning entitlements equals 0.

Comment 1 Grant Gainey 2016-02-03 19:57:29 UTC
The problem with removing access to the Config tab when an org loses Provisioning, is that it doesn't just remove the ability to do provisioning-things to their systems - it keeps them from accessing the config-files they've set up. This is Rude.

Generally, once an org has had access to any of the 'unlockable' functionality, we don't remove it even if they lose the entitlement. Individual systems will no longer be able to BE provisioned, because that's controlled by "do they have the Provisioning entitlement assigned" - but the customer data the user has stored in Satellite should remain available.


Note You need to log in before you can comment on or make changes to this bug.