Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1123385 - Adding hosts to RHEV-M results in error message
Summary: Adding hosts to RHEV-M results in error message
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Frantisek Kobzik
QA Contact: Pavel Novotny
URL:
Whiteboard: virt
: 1123280 (view as bug list)
Depends On:
Blocks: 1126800 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-25 13:31 UTC by Bill Sanford
Modified: 2015-02-17 08:25 UTC (History)
17 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1126800 (view as bug list)
Environment:
Last Closed: 2015-02-17 08:25:28 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30878 master MERGED core: RNG fixes Never
oVirt gerrit 30911 ovirt-engine-3.5 MERGED core: RNG fixes Never

Description Bill Sanford 2014-07-25 13:31:24 UTC
Description of problem:
When I try to add a host to RHEV-M, I get an error message: "Host corrin does not comply with the cluster Default Random Number Generator sources. The Hosts supported sources are: Non interactive user; and the cluster requirements are: RANDOM."

Version-Release number of selected component (if applicable):
RHEV-M 3.5 (vt1.3/el6)

How reproducible:
100% 

Steps to Reproduce:
1. 
2. 
3. 

Actual results:


Expected results:


Additional info:

On 7-25 @ 9:05 am in #rhev-dev in IRC:

<bsanford> Can anyone tell me if there are more settings in RHEV-M 3.5 anyone should know about? I am trying to add a host to a 3.5 install and I get an error message: Host corrin does not comply with the cluster Default Random Number Generator sources. The Hosts supported sources are: Non interactive user; and the cluster requirements are: RANDOM.

Comment 2 Oved Ourfali 2014-07-27 05:09:48 UTC
*** Bug 1123280 has been marked as a duplicate of this bug. ***

Comment 3 Oved Ourfali 2014-07-27 07:13:42 UTC
This is a virt issue. Changing properly.

Comment 4 Michal Skrivanek 2014-07-28 08:16:32 UTC
changing properly;-)

Comment 5 Michal Skrivanek 2014-07-28 11:19:12 UTC
RNG devices shouldn't be required in Default cluster

Comment 6 Douglas Schilling Landgraf 2014-08-04 23:37:18 UTC
Hi,

I got the same error message trying to approve oVirt Node 3.5:

"Host xxxxx does not comply with the cluster Default Random Number Generator sources. The Hosts supported sources are: Non interactive user; and the cluster requirements are: RANDOM.".

Can we proceed and merge the patches in 3.5 tree?

Thanks

Comment 7 Sandro Bonazzola 2014-08-05 10:12:17 UTC
Please clone to oVirt and make it block bug #1073943.
I think that this is worth blocking the RC release.

Comment 8 Pavel Novotny 2014-09-01 16:22:31 UTC
Verified upstream in ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch (rc1.1).

Verification steps:
1. Clean installation of ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
2. In GUI, edit the Default cluster and check 'Required Random Number Generator sources'.

Results:
By default, all RNG sources are disabled (not checked) on the Default cluster (as well as on other newly created clusters).

Comment 9 Omer Frenkel 2015-02-17 08:25:28 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.