Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1122772 - yum repolist does not inform "This system is not yet registered" when the system is unregistered.
Summary: yum repolist does not inform "This system is not yet registered" when the sys...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-07-24 04:02 UTC by qianzhan
Modified: 2014-10-14 07:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: yum repolist does not inform "This system is not yet registered" when the system is unregistered. Consequence: n/a Fix: Notify user system is not registered. Result: yum repolist now notifies the user the system is not registered.
Clone Of:
Environment:
Last Closed: 2014-10-14 07:47:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description qianzhan 2014-07-24 04:02:23 UTC
Description of problem:
yum repolist does not inform "This system is not yet registered" when the system is unregistered.

Version-Release number of selected component (if applicable):
subscription-manager: 1.12.4-1.el6
python-rhsm: 1.12.4-1.el6


How reproducible:
always

Steps to Reproduce:
1. Make sure the system is not registered.
[root@dhcp-14-238 ~]# subscription-manager identity
This system is not yet registered. Try 'subscription-manager register --help' for more information.


2. yum repolist.
[root@dhcp-14-238 ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
repolist: 0


Actual results:
As step 2, the result of yum repolist is 0, but no explanation for the result.

Expected results:
An explanation, like "This system is not yet registered. Try 'subscription-manager register --help' for more information", should be displayed for why yum repolist is 0.

Additional info:

Comment 2 Chris Snyder 2014-07-28 13:36:09 UTC
Should be in master as of commit: 384208585272a25eea06a7c3db538bc84194c17d

Comment 4 qianzhan 2014-08-14 03:16:52 UTC
Verifying version: RHEL-6.6-20140812.1

[root@dhcp-14-148 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: Unknown
subscription management rules: Unknown
subscription-manager: 1.12.10-1.el6
python-rhsm: 1.12.5-1.el6

Verification:

[root@dhcp-14-148 ~]# subscription-manager identity
This system is not yet registered. Try 'subscription-manager register --help' for more information.
[root@dhcp-14-148 ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
repolist: 0
[root@dhcp-14-148 ~]#

The bug still exists in build RHEL-6.6-20140812.1, so move it form "ON_QA" to "ASSIGNED"

Comment 5 John Sefler 2014-08-20 23:29:43 UTC
The fix (In reply to qianzhan from comment #4)
> Verifying version: RHEL-6.6-20140812.1
> 
> [root@dhcp-14-148 ~]# subscription-manager version
> server type: This system is currently not registered.
> subscription management server: Unknown
> subscription management rules: Unknown
> subscription-manager: 1.12.10-1.el6
> python-rhsm: 1.12.5-1.el6
> 
> The bug still exists in build RHEL-6.6-20140812.1, so move it form "ON_QA"
> to "ASSIGNED"

The fix applied in comment 2 will appear in subscription-manager-1.12.11-1

Comment 6 John Sefler 2014-08-20 23:34:14 UTC
Note that this bug is actually reverting the removal of some "This system is not registered to..." messages from bug 1058380 thrown by the subscription-manager yum plugin.

Comment 7 Shwetha Kallesh 2014-08-21 06:41:30 UTC
Marking verified!! I see an explaination that system ins not registered.

[root@shwetha-ws ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.21-1
subscription management rules: 5.11
subscription-manager: 1.12.13-1.el6
python-rhsm: 1.12.5-1.el6



[root@shwetha-ws ~]# subscription-manager identity
This system is not yet registered. Try 'subscription-manager register --help' for more information.
[root@shwetha-ws ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
repo id                                                                       repo name                                                                           status
rhel-6.6-blr                                                                  RHEL 6.6 BLR repo                                                                   3,783
rhel-6.6-blr-optional                                                         RHEL 6.6 BLR repo Optional

Comment 9 errata-xmlrpc 2014-10-14 07:47:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.