Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 112259 - net install: feature request: progress meter for downloading files
Summary: net install: feature request: progress meter for downloading files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
: 243561 252224 455973 (view as bug list)
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2003-12-16 19:15 UTC by Matthew Callaway
Modified: 2008-08-27 15:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-27 15:31:19 UTC


Attachments (Terms of Use)

Description Matthew Callaway 2003-12-16 19:15:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
The netstg2.img is 12 MB.  It takes a while to download this file,
even with broadband connections.  It would be nice to have a progress
meter.  Currently, it is easy to think that the install simply failed,
or hung, as the file is transferred to a file descriptor.

Version-Release number of selected component (if applicable):
anaconda: core 1

How reproducible:
Always

Steps to Reproduce:
1. Start net install
2. Select a mirror
3. Watch the "retrieving netstg2.img" portion
    

Additional info:

Comment 1 Jeremy Katz 2003-12-16 21:33:26 UTC
Will consider as time allows.

Comment 2 Bastien Nocera 2004-06-16 16:15:17 UTC
Passing on for Fedora Core 2.

Comment 3 Rahul Sundaram 2005-08-14 02:35:56 UTC
ping

Comment 4 Chris Lumens 2007-08-15 15:06:33 UTC
*** Bug 252224 has been marked as a duplicate of this bug. ***

Comment 5 Chris Lumens 2007-08-30 21:48:45 UTC
*** Bug 243561 has been marked as a duplicate of this bug. ***

Comment 6 Qian Cai 2008-07-19 15:31:26 UTC
*** Bug 455973 has been marked as a duplicate of this bug. ***

Comment 7 Qian Cai 2008-07-19 15:37:53 UTC
Hi, any progress on this feature? It is a kind of annoy for users in places like
China, because there is usually no fast ftp/http mirror to use. It took
something like half of hour to download stage2.img file. Without any progress
information, those users are suffering from bad user experiences.

Comment 8 Andy Lindeberg 2008-08-27 15:31:19 UTC
This has been implemented in Rawhide. Please give it a try and let us know if you have any problems.


Note You need to log in before you can comment on or make changes to this bug.