Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1122051 - No information available on WebUI that config-folder comparison is not supported.
Summary: No information available on WebUI that config-folder comparison is not suppo...
Keywords:
Status: CLOSED DUPLICATE of bug 1004746
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 560
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-07-22 12:47 UTC by Dimitar Yordanov
Modified: 2014-07-22 19:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-22 19:25:04 UTC


Attachments (Terms of Use)

Description Dimitar Yordanov 2014-07-22 12:47:59 UTC
Description of problem:
Obviously  config-folder comparison on WebUI is not supported but there are no restrictions to do so.

Version-Release number of selected component (if applicable):
spacewalk-java-2.0.2-78

How reproducible:
100%

Steps to Reproduce:
1. Create configuration channel via WebUI.
2. Create  configuration folder in the channel.
3. Register a client to Satellite.
4. Add tools channel to the client and execute:
    yum install rhncfg*
    rhn-actions-control --enable-all
5. Assign the configuration channel to the client.
6. Deploy the configuration folder.
    rhncfg-client get
7. Change the owner of the folder that has been just deployed.
8. rhncfg-client verify
user /tmp/folder
  
7. Schedule comparison of the deployed folder via WebUI.

Actual results:

This action's status is: Completed.
The client picked up this action on 07/22/14 6:28:38 AM EDT.
The client completed this action on 07/22/14 6:28:48 AM EDT.
Client execution returned "Files successfully diffed" (code 0)
Config Files:
/tmp/folder (rev. 1)

Expected results:
Some warning this operation is not supported via WebUI.


Additional info:
/usr/share/rhn/actions/configfiles.py

341  ->	        if os.path.isdir(path):
342  	            # We dont support dir diffs, ignore
343  	            continue

Comment 1 Stephen Herr 2014-07-22 19:25:04 UTC
I'm choosing to treat this as a bug in the implementation of 1004746 rather than a bug in explaining what is not supported. We do in fact support comparing directories deployed through config management - if you are using the 'rhncfg-client verify' tool. If the command-line client can do something then an action scheduled through the webui should be able to do it to.

*** This bug has been marked as a duplicate of bug 1004746 ***


Note You need to log in before you can comment on or make changes to this bug.