Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1121998 - RHEV-H 20140603.2 - new FC LUNs not visible
Summary: RHEV-H 20140603.2 - new FC LUNs not visible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Nir Soffer
QA Contact: Elad
URL:
Whiteboard: storage
Depends On:
Blocks: 1123637 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-22 10:26 UTC by Evgheni Dereveanchin
Modified: 2018-12-09 18:13 UTC (History)
14 users (show)

Fixed In Version: v4.16.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1123637 (view as bug list)
Environment:
Last Closed: 2015-02-11 21:12:12 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0159 normal SHIPPED_LIVE vdsm 3.5.0 - bug fix and enhancement update 2015-02-12 01:35:58 UTC
oVirt gerrit 27122 None None None Never
oVirt gerrit 30984 ovirt-3.5 MERGED multipath: Rescan also FC devices Never

Description Evgheni Dereveanchin 2014-07-22 10:26:03 UTC
Description of problem:
when using RHEV-H 20140603.2 hosts, opening the "Add Storage" menu o nthe RHEV-M does not seem to trigger a SCSI rescan on the SPM, so newly provisioned LUNs remain unvisible to the host

Version-Release number of selected component (if applicable):
RHEV-H 20140603.2 (vdsm 4.14.7-3)
RHEV-M 3.3
RHEV-M 3.4

How reproducible:
always

Steps to Reproduce:
1. provision LUN
2. make it accessible to all hosts
3. try to create a new storage domain on this LUN

Actual results:
new LUN not visible in the list on RHEV-M or on the RHEV-H multipath output

Expected results:
new LUN visible and usable for storage tasks

Comment 3 Allon Mureinik 2014-07-23 06:12:00 UTC
Please attach the engine and VDSM logs.

Comment 4 Daniel Erez 2014-07-23 06:29:59 UTC
@Nir - is it already solved by Change-Id: I7699504f9771232ee0b880f9c83a51fd5b90f40e

Comment 5 Nir Soffer 2014-07-23 09:42:47 UTC
(In reply to Daniel Erez from comment #4)
> @Nir - is it already solved by Change-Id:
> I7699504f9771232ee0b880f9c83a51fd5b90f40e

It seems to be solved by http://gerrit.ovirt.org/27122.

Comment 8 Allon Mureinik 2014-07-27 08:42:11 UTC
(In reply to Nir Soffer from comment #5)
> (In reply to Daniel Erez from comment #4)
> > @Nir - is it already solved by Change-Id:
> > I7699504f9771232ee0b880f9c83a51fd5b90f40e
> 
> It seems to be solved by http://gerrit.ovirt.org/27122.
So let's please backport this fix to 3.5 and 3.4.z.

Comment 9 Nir Soffer 2014-07-27 10:47:48 UTC
(In reply to Allon Mureinik from comment #8)
> So let's please backport this fix to 3.5 and 3.4.z.
qa ack is missing.

Comment 10 Allon Mureinik 2014-07-27 10:54:51 UTC
(In reply to Nir Soffer from comment #9)
> (In reply to Allon Mureinik from comment #8)
> > So let's please backport this fix to 3.5 and 3.4.z.
> qa ack is missing.

Aharon/Nati/Gil - please examine for qa ack/nack for inclusion in 3.4.2.

Comment 12 Allon Mureinik 2014-07-27 12:30:58 UTC
(In reply to Nir Soffer from comment #9)
> (In reply to Allon Mureinik from comment #8)
> > So let's please backport this fix to 3.5 and 3.4.z.
> qa ack is missing.

All acks are granted - please backport to 3.5.0.

Comment 13 Elad 2014-09-15 11:07:30 UTC
New FC LUNs mapped to the host are being live listed in the devices list the host is exposed to.
Tested against XtremIO storage server.

Verified using rhev3.5 vt3.1  vdsm-4.16.3-3.el7.beta.x86_64

Comment 14 Tahlia Richardson 2015-01-16 01:44:52 UTC
Hi,
Since the requires_doc_text flag has been set to ?, please provide draft doc text in the format of: 

Cause:
Consequence:
Fix:
Result:

Thanks,
Tahlia

Comment 15 Nir Soffer 2015-02-02 13:22:22 UTC
This is a duplicate of bug 1159839, which has a good description of the fix.

Comment 20 errata-xmlrpc 2015-02-11 21:12:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0159.html


Note You need to log in before you can comment on or make changes to this bug.