Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1120565 - Thrown ImportError: No module named bottle when using "ovirt-node-features -d"
Summary: Thrown ImportError: No module named bottle when using "ovirt-node-features -d"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1151906
Blocks: rhevh-7.0 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-17 07:27 UTC by haiyang,dong
Modified: 2016-02-10 20:04 UTC (History)
9 users (show)

Fixed In Version: rhev-hypervisor6-6.6-20141218.0.iso rhev-hypervisor7-7.0-20141218.0.iso
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:00:03 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 30201 master MERGED ovirt-node-features: Do not document daemon mode Never

Description haiyang,dong 2014-07-17 07:27:41 UTC
Description of problem:
when using "ovirt-node-features -d" to launches the http daemon on port 8082
failed with follow error info:
[root@dhcp-66-73-86 admin]# ovirt-node-features -d
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
  File "/usr/lib/python2.7/site-packages/ovirt/node/tools/features.py", line 100, in <module>
  File "/usr/lib/python2.7/site-packages/ovirt/node/tools/features.py", line 41, in launch_bottle
ImportError: No module named bottle


Version-Release number of selected component (if applicable):
ovirt-node-3.1.0-0.5.20140711git7197118.el7.noarch.rpm
rhev-hypervisor7-7.0-20140714.0.iso

How reproducible:
100%


Steps to Reproduce:


Actual results:


Expected results:


Additional info:

Comment 1 Fabian Deutsch 2014-07-17 08:18:19 UTC
Lowering priority as the feature should not be used on RHEL (we do not want to import another python module).

To address this the documentation was adjusted to not document the flag.

Comment 2 Fabian Deutsch 2014-07-24 16:02:33 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 4 haiyang,dong 2014-10-13 02:52:11 UTC
need to wait for Bug 1151906 to been fixed to verify this bug.

Comment 6 haiyang,dong 2014-12-18 01:41:41 UTC
Test version
rhev-hypervisor7-7.0-20141212.0.iso
ovirt-node-3.1.0-0.34.20141210git0c9c493.el7.noarch
ovirt-node-plugin-hosted-engine-0.2.0-6.0.el7ev.x86_64

Test steps:
[root@dhcp-9-55 admin]# ovirt-node-features --help
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
  File "/usr/lib/python2.7/site-packages/ovirt/node/tools/features.py", line 94, in <module>
  File "/usr/lib/python2.7/site-packages/ovirt/node/setup/hostedengine/__init__.py", line 34, in createPluginFeatures
NameError: global name 'Feature' is not defined

so need assigned this bug again.

Comment 7 Fabian Deutsch 2014-12-18 14:45:44 UTC
Hosted-Engine will be disabled in 3.5.0 (introduced in 3.5.1) so moving this bug back to MODIFIED. Once a new build is available it will be moved to ON_QA.

teh original traceback was also different.

Comment 8 haiyang,dong 2015-01-13 08:54:20 UTC
Test version:
rhev-hypervisor7-7.0-20150112.0.el7ev
ovirt-node-3.1.0-0.42.20150109gitd06b7c5.el7.noarch

Test steps:
1. [root@dhcp-10-54 admin]# ovirt-node-features --help
Get a feature summary about this node.
Usage: /usr/lib/python2.7/site-packages/ovirt/node/tools/features.pyc [dumpxml]

2. [root@dhcp-10-54 admin]# ovirt-node-features dumpxml
<?xml version='1.0' encoding='utf-8'?>
<node version="0.1">
  <features>
    <feature description="Has a UI" name="ui" namespace="ovirt.node.setup.core" owner="ovirt.node.setup.core" version=""/>
    <feature description="Offers RHN Registration                                  via RHN" name="RHN" namespace="ovirt.node.setup.rhn" owner="ovirt.node.setup.rhn" version=""/>
    <feature description="Offers informations via SNMP" name="snmp" namespace="ovirt.node.setup.snmp" owner="ovirt.node.setup.snmp" version=""/>
    <feature description="This feature represents the CPE of this product" name="version" namespace="cpe" owner="__main__" version="">cpe:/o:redhat:enterprise_linux:7:update0:hypervisor</feature>
    <feature description="Offers informations via CIM" name="cim" namespace="ovirt.node.setup.cim" owner="ovirt.node.setup.cim" version=""/>
  </features>
  <methods/>
</node>

NO ImportError exception was thrown when using "ovirt-node-features --help/dumpxml". So this bug has been fixed, change the status into "VERIFIED".

Comment 10 errata-xmlrpc 2015-02-11 21:00:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.