Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1119436 - rhevm-dwh-setup fails upgrading to 3.3.4-1
Summary: rhevm-dwh-setup fails upgrading to 3.3.4-1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.3.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: movciari
URL:
Whiteboard: integration
Depends On:
Blocks: 1121642 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-14 19:03 UTC by Amador Pahim
Modified: 2018-12-06 17:21 UTC (History)
16 users (show)

Fixed In Version: vt1.5 - rhevm-dwh-3.5.0-1.el6_5
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1121642 (view as bug list)
Environment:
Last Closed: 2015-02-11 18:15:46 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1128533 None None None Never
Red Hat Product Errata RHEA-2015:0177 normal SHIPPED_LIVE rhevm-dwh 3.5 bug fix and enhancement update 2015-02-11 23:11:50 UTC
oVirt gerrit 30511 ovirt-engine-dwh-3.3 MERGED packaging: setup: fix updating pg_hba.conf Never

Description Amador Pahim 2014-07-14 19:03:28 UTC
Description of problem:

rhevm-setup can upgrade from 3.2 to 3.3, but fails to start ovirt-engine-dwhd. I have to start ovirt-engine service manually, but when running rhevm-dwh-setup, I face the error: 

2014-07-14 14:03:47::DEBUG::common_utils::972::root:: retcode = 2
2014-07-14 14:03:49::DEBUG::common_utils::1477::root:: starting runPostgresSuQuery database: template1 query: "select 1;"
2014-07-14 14:03:49::DEBUG::common_utils::915::root:: Executing command --> '/bin/su -l postgres -c /usr/bin/psql -U postgres -d template1 -tA -c "select 1;"' in work
ing directory '/etc/ovirt-engine'
2014-07-14 14:03:49::DEBUG::common_utils::970::root:: output =
2014-07-14 14:03:49::DEBUG::common_utils::971::root:: stderr = Password for user postgres:
psql: fe_sendauth: no password supplied

2014-07-14 14:03:49::DEBUG::common_utils::972::root:: retcode = 2
2014-07-14 14:03:51::ERROR::rhevm-dwh-setup::703::root:: Exception caught!
2014-07-14 14:03:51::ERROR::rhevm-dwh-setup::704::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-dwh-setup", line 461, in main
    pg_updated = utils.configHbaIdent()
  File "/usr/share/ovirt-engine-dwh/common_utils.py", line 1448, in configHbaIdent
    restartPostgres(newval=='md5')
  File "/usr/share/ovirt-engine-dwh/common_utils.py", line 890, in restartPostgres
    startPostgres()
  File "/usr/share/ovirt-engine-dwh/common_utils.py", line 559, in startPostgres
    'Error: postgresql service couldn\'t be started. Stopping.'
RuntimeError: Error: postgresql service couldn't be started. Stopping.


Version-Release number of selected component (if applicable):

From:
rhevm-3.2.6-0.50.el6ev.noarch
rhevm-dwh-3.2.4-1.el6ev.noarch

To:
rhevm-3.3.4-0.53.el6ev.noarch
rhevm-dwh-3.3.4-1.el6ev.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install/configure latest RHEVM/DWH/REPORTS 3.2.
2. Run: yum update rhevm-setup rhevm-dwh rhevm-reports
3. Run: rhevm-setup
 
*Setup seems to fail with error:
  Starting ovirt-**FILTERED**-dwhd: at Mon Jul 14 15:01:14 BRT 2014[FAILED]

4. Start ovirt-engine anyway: service ovirt-engine start
5. Engine is working.
6. Run: rhevm-dwh-setup

* dwh-setup will not complete. Log is showing the mentioned message:
  psql: fe_sendauth: no password supplied



Workaround:

Change pg_hba.conf from:
--------------------------------------------------------------
# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

# "local" is for Unix domain socket connections only
local   all         all                               md5
# IPv4 local connections:
host    all         all         127.0.0.1/32          md5
# IPv6 local connections:
host    all         all         ::1/128               md5
--------------------------------------------------------------
To:
--------------------------------------------------------------
# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

# "local" is for Unix domain socket connections only
local   all         all                               ident
# IPv4 local connections:
host    all         all         127.0.0.1/32          md5
# IPv6 local connections:
host    all         all         ::1/128               md5
--------------------------------------------------------------

After the change, "rhevm-dwh-setup" will complete.

Comment 1 Shirly Radco 2014-07-15 08:38:56 UTC
This should be fixed for 3.4/3.5.
3.2 is a very old version so since there is a workaround i'm not sure the effort is worth it.

Barak, what do you think?

Comment 3 Yedidyah Bar David 2014-07-20 07:49:04 UTC
(In reply to Amador Pahim from comment #0)
> Description of problem:
> 
> rhevm-setup can upgrade from 3.2 to 3.3, but fails to start
> ovirt-engine-dwhd. I have to start ovirt-engine service manually, but when
> running rhevm-dwh-setup, I face the error: 
> 
> 2014-07-14 14:03:47::DEBUG::common_utils::972::root:: retcode = 2
> 2014-07-14 14:03:49::DEBUG::common_utils::1477::root:: starting
> runPostgresSuQuery database: template1 query: "select 1;"
> 2014-07-14 14:03:49::DEBUG::common_utils::915::root:: Executing command -->
> '/bin/su -l postgres -c /usr/bin/psql -U postgres -d template1 -tA -c
> "select 1;"' in work
> ing directory '/etc/ovirt-engine'
> 2014-07-14 14:03:49::DEBUG::common_utils::970::root:: output =
> 2014-07-14 14:03:49::DEBUG::common_utils::971::root:: stderr = Password for
> user postgres:
> psql: fe_sendauth: no password supplied
> 
> 2014-07-14 14:03:49::DEBUG::common_utils::972::root:: retcode = 2
> 2014-07-14 14:03:51::ERROR::rhevm-dwh-setup::703::root:: Exception caught!
> 2014-07-14 14:03:51::ERROR::rhevm-dwh-setup::704::root:: Traceback (most
> recent call last):
>   File "/usr/bin/rhevm-dwh-setup", line 461, in main
>     pg_updated = utils.configHbaIdent()
>   File "/usr/share/ovirt-engine-dwh/common_utils.py", line 1448, in
> configHbaIdent
>     restartPostgres(newval=='md5')
>   File "/usr/share/ovirt-engine-dwh/common_utils.py", line 890, in
> restartPostgres
>     startPostgres()
>   File "/usr/share/ovirt-engine-dwh/common_utils.py", line 559, in
> startPostgres
>     'Error: postgresql service couldn\'t be started. Stopping.'
> RuntimeError: Error: postgresql service couldn't be started. Stopping.
> 
> 
> Version-Release number of selected component (if applicable):
> 
> From:
> rhevm-3.2.6-0.50.el6ev.noarch
> rhevm-dwh-3.2.4-1.el6ev.noarch
> 
> To:
> rhevm-3.3.4-0.53.el6ev.noarch
> rhevm-dwh-3.3.4-1.el6ev.noarch
> 
> 
> How reproducible:
> 100%
> 
> 
> Steps to Reproduce:
> 1. Install/configure latest RHEVM/DWH/REPORTS 3.2.
> 2. Run: yum update rhevm-setup rhevm-dwh rhevm-reports
> 3. Run: rhevm-setup
>  
> *Setup seems to fail with error:
>   Starting ovirt-**FILTERED**-dwhd: at Mon Jul 14 15:01:14 BRT 2014[FAILED]
> 
> 4. Start ovirt-engine anyway: service ovirt-engine start
> 5. Engine is working.
> 6. Run: rhevm-dwh-setup
> 
> * dwh-setup will not complete. Log is showing the mentioned message:
>   psql: fe_sendauth: no password supplied
> 
> 
> 
> Workaround:
> 
> Change pg_hba.conf from:
> --------------------------------------------------------------
> # TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD
> 
> # "local" is for Unix domain socket connections only
> local   all         all                               md5
> # IPv4 local connections:
> host    all         all         127.0.0.1/32          md5
> # IPv6 local connections:
> host    all         all         ::1/128               md5
> --------------------------------------------------------------
> To:
> --------------------------------------------------------------
> # TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD
> 
> # "local" is for Unix domain socket connections only
> local   all         all                               ident
> # IPv4 local connections:
> host    all         all         127.0.0.1/32          md5
> # IPv6 local connections:
> host    all         all         ::1/128               md5
> --------------------------------------------------------------
> 
> After the change, "rhevm-dwh-setup" will complete.

Is this reproducible? I think that if this (md5 vs ident for local) is the only change needed to fix it, it should have worked even without it. Perhaps there was some other local manual change that together with this one caused a problem.
Note that we recently fixed a related bug #1111131 (in 3.3), might be related.

Comment 11 Yedidyah Bar David 2014-07-22 06:36:10 UTC
Moving to qa, 3.5 should not be affected.

Comment 14 errata-xmlrpc 2015-02-11 18:15:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0177.html


Note You need to log in before you can comment on or make changes to this bug.