Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1118361 - [WGT] uninstalled message is not seen in vdsm.log after WGT were uninstalled in Windows guest
Summary: [WGT] uninstalled message is not seen in vdsm.log after WGT were uninstalled ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Windows Guest Tools
Version: 3.4.0
Hardware: All
OS: Windows
high
high
Target Milestone: ---
: 3.5.0
Assignee: Lev Veyde
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks: 1119783 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-10 14:04 UTC by Jiri Belka
Modified: 2015-02-11 17:41 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1119783 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:41:50 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
agent uninstall log (deleted)
2014-07-10 14:04 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0198 normal SHIPPED_LIVE rhev-guest-tools-iso bug fix and enhancement update 2015-02-11 22:34:00 UTC

Description Jiri Belka 2014-07-10 14:04:25 UTC
Created attachment 917100 [details]
agent uninstall log

Description of problem:
uninstalled message is not seen in vdsm.log after WGT were uninstalled in Windows guest. it used to work.

3.4.5: VM Channels Listener::DEBUG::2014-07-10 13:41:09,024::guestIF::284::vm.Vm::(_handleMessage) vmId=`257b1a2a-08dc-44b8-9c1f-8d6ce3f41af4`::RHEV agent was uninstalled.

3.4.7: VM Channels Listener::DEBUG::2014-07-10 13:47:55,368::guestIF::284::vm.Vm::(_handleMessage) vmId=`257b1a2a-08dc-44b8-9c1f-8d6ce3f41af4`::RHEV agent was uninstalled.

3.4.8: missing

from uninstall log:

~~~
InstallShield 14:58:27: Invoking script function HcCalls
1: MsiGetProperty(503, VIRTDEVICENAME, ,0);
1: -1 = CreateFileA ( , GENERIC_WRITE,0,0,OPEN_EXISTING,0,0)
1: 0 = WriteFile ( -1, { "__name__" : "uninstalled" }, 16,0,0 )
1: 0 = CloseHandle ( -1 )
InstallShield 14:58:27: CallScriptFunctionFromMsiCA() ends
InstallShield 14:58:27: Cleaning up temp file C:\Users\ADMINI~1\AppData\Local\Temp\{D56FC7BA-2C2F-4481-B55D-E4B06476D5EA}\ISBEW64.exe
InstallShield 14:58:27: Could not delete temp file C:\Users\ADMINI~1\AppData\Local\Temp\{D56FC7BA-2C2F-4481-B55D-E4B06476D5EA}\ISBEW64.exe
InstallShield 14:58:27: Cleaning up temp file C:\Users\ADMINI~1\AppData\Local\Temp\{D56FC7BA-2C2F-4481-B55D-E4B06476D5EA}\ISRT.dll
InstallShield 14:58:27: Cleaning up temp file C:\Users\ADMINI~1\AppData\Local\Temp\{D56FC7BA-2C2F-4481-B55D-E4B06476D5EA}\IsConfig.ini
InstallShield 14:58:27: Cleaning up temp file C:\Users\ADMINI~1\AppData\Local\Temp\{D56FC7BA-2C2F-4481-B55D-E4B06476D5EA}\String1033.txt
InstallShield 14:58:27: Cleaning up temp file C:\Users\ADMINI~1\AppData\Local\Temp\{D56FC7BA-2C2F-4481-B55D-E4B06476D5EA}\_isres_0x0409.dll
InstallShield 14:58:27: Cleaning up temp file C:\Users\ADMINI~1\AppData\Local\Temp\{D56FC7BA-2C2F-4481-B55D-E4B06476D5EA}\setup.inx
InstallShield 14:58:27: Could not delete temp folder C:\Users\ADMINI~1\AppData\Local\Temp\{D56FC7BA-2C2F-4481-B55D-E4B06476D5EA}
Action ended 14:58:27: HcCalls. Return value 1.
Action ended 14:58:27: INSTALL. Return value 1." : "uninstalled" }, 16,0,0 )
1: 0 = CloseHandle ( -1 ) 
~~~

Version-Release number of selected component (if applicable):
3.4.8

How reproducible:
100%

Steps to Reproduce:
1. tail -f /var/log/vdsm/vdsm.log | grep uninstalled
2. uninstall WGT
3.

Actual results:
3.4.8 - can't see uninstalled msg thus appsList is not reset

Expected results:
should be seen

Additional info:

Comment 1 Jiri Belka 2014-07-10 14:05:22 UTC
found on w2k12 but should probably seen on every Windows OS

Comment 6 Jiri Belka 2014-08-29 13:09:26 UTC
ok, 3.5.2

Comment 7 Sandro Bonazzola 2014-11-21 09:02:25 UTC
Lev, can you fill doctext or mark this as doctext not needed?

Comment 9 errata-xmlrpc 2015-02-11 17:41:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0198.html


Note You need to log in before you can comment on or make changes to this bug.