Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1116785 - multicast mac address should be filtered by hosted-engine-setup
Summary: multicast mac address should be filtered by hosted-engine-setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Petr Kubica
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-07 10:14 UTC by Jiri Moskovcak
Modified: 2015-02-11 20:40 UTC (History)
10 users (show)

Fixed In Version: ovirt-hosted-engine-setup-1.2.0-0.2.master.el6_5
Doc Type: Bug Fix
Doc Text:
The use of multicast MAC addresses is not supported by libvirt. Previously, the hosted engine deployment wizard was not verifying the validity of a provided MAC address and the wizard was failing with an unexpected error. Now, MAC addresses are verified and the user is prompted to enter the address again if it is not valid.
Clone Of:
Environment:
Last Closed: 2015-02-11 20:40:21 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
vdsm log (deleted)
2014-07-07 10:50 UTC, Jiri Moskovcak
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0161 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2015-12-07 21:35:11 UTC
oVirt gerrit 30784 master MERGED packaging: setup: validate unicast MAC address Never
oVirt gerrit 30926 ovirt-hosted-engine-setup-1.2 MERGED packaging: setup: validate unicast MAC address Never

Description Jiri Moskovcak 2014-07-07 10:14:34 UTC
Description of problem:
When trying to install hosted engine I got the error in $(summ). Please see the attached log for more details

Version-Release number of selected component (if applicable):
vdsm-4.14.7-4.el6ev.x86_64
libvirt-0.10.2-29.el6_5.9.x86_64
ovirt-hosted-engine-setup-1.1.3-1.el6ev.noarch
ovirt-hosted-engine-ha-1.1.2-5.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. install ovirt-hosted-engine-setup
2. run hosted-engine --deploy
3. watch it die..

Actual results:
Setup fails to create the VM for the engine.

Comment 1 Jiri Moskovcak 2014-07-07 10:50:08 UTC
Created attachment 916035 [details]
vdsm log

Comment 2 Jiri Moskovcak 2014-07-07 10:55:10 UTC
As it turned out, I made a typo when entering a mac address and entered multicast mac. As it seems libvirt doesn't allow multicast mac address which lead to this error. So I think the right place to fix this is in the setup and prevent user from entering wrong mac. This [1] is the commit in libvirt which adds the check, so you can use the same pattern to validate the mac in the setup.

[1] http://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=0007237301586aa90f58a7cc8d7cb29a16b00470

Comment 3 Sandro Bonazzola 2014-07-08 12:21:34 UTC
Original subject was: AttributeError: 'NoneType' object has no attribute 'XMLDesc' (referenced in comment #0)

Comment 4 Petr Kubica 2014-11-14 15:09:09 UTC
Verified in ovirt-hosted-engine-setup-1.2.1-3.el6ev.noarch

You may specify a unicast MAC address for the VM or accept a randomly generated default [00:16:3e:02:ef:e0]: 01:1A:4C:10:3F:11
[ ERROR ] Invalid unicast MAC address specified: '01:1A:4C:10:3F:11'

Also tried with:
33:33:xx:xx:xx:xx
01:00:5E:xx:xx:xx
01:00:0C:CC:CC:CC
01:00:0C:CC:CC:CD
01:80:C2:00:00:00
etc..

Comment 7 errata-xmlrpc 2015-02-11 20:40:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0161.html


Note You need to log in before you can comment on or make changes to this bug.