Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1116416 - engine serves only English docs when other locales are installed
Summary: engine serves only English docs when other locales are installed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Greg Sheremeta
QA Contact: Jiri Belka
URL:
Whiteboard: ux
Depends On:
Blocks: 1118920 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-04 13:45 UTC by Greg Sheremeta
Modified: 2015-02-16 13:35 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1118920 (view as bug list)
Environment:
Last Closed: 2015-02-16 13:35:35 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
full description and solution with screenshots (deleted)
2014-07-04 13:49 UTC, Greg Sheremeta
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29585 None None None Never

Description Greg Sheremeta 2014-07-04 13:45:29 UTC
Description of problem:
I installed Japanese docs. When I clicked on the Japanese admin guide link, I was
redirected to the English copy.

See attached PDF for full description and solution, with screenshots

Version-Release number of selected component (if applicable):
3.4.0

How reproducible:
Always

Steps to Reproduce:
1. Install Japanese docs
2. Open RHEV-M welcome page
3. Switch to Japanese locale
4. Click on Admin Guide (or any other doc link)

Actual results:
English copy is served

Expected results:
Japanese copy is served.

Additional info:
See attached PDF for full description and solution, with screenshots

Comment 1 Greg Sheremeta 2014-07-04 13:49:25 UTC
Created attachment 914722 [details]
full description and solution with screenshots

Comment 2 Einav Cohen 2014-07-10 17:33:43 UTC
Greg:

- I've noticed that you put a '3.4.1' target release for this bug. 
Since 3.4 has already GA'd, the process is:
* open a BZ for 3.5 
* solve BZ for 3.5
* clone 3.5 BZ for 3.4.z 
* solve BZ for 3.4.z (typically by backporting to the relevant branch). 

So I am turning this BZ to a 3.5 BZ (by flagging it with "rhevm‑3.5.0?") and suggesting it as a candidate for 3.4.z (by flagging it *also* with "rhevm‑3.4.z?"). 
Once this BZ is fully acked, I will clone it to 3.4.z, and you will be able to backport it to 'ovirt-engine-3.4'.

- I see that the patch associated with this BZ was already merged to 'master', and it was done right before the 'ovirt-engine-3.5' branching; which means that the fix is already there for 3.5. Which means that this BZ can move to MODIFIED (unless there are additional patches that need to be written in order to solve the issue)? if so - please move it. thanks.

Comment 4 Greg Sheremeta 2014-07-11 21:55:57 UTC
ack

Comment 7 Jiri Belka 2014-07-29 14:19:05 UTC
This needs to wait for real d/s build as upstream doesn't ship docs.

Comment 8 Jiri Belka 2014-09-08 07:53:50 UTC
ok

rhevm-webadmin-portal-3.5.0-0.10.master.el6ev.noarch
rhevm-doc-ja-JP-3.4.0-0.el6eng.noarch


Note You need to log in before you can comment on or make changes to this bug.