Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1116175 - RedHat support plugin for rhev not able to collect sosreports from hypervisors
Summary: RedHat support plugin for rhev not able to collect sosreports from hypervisors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Spenser Shumaker
QA Contact: Jiri Belka
URL:
Whiteboard: subeng
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-04 01:03 UTC by Aval
Modified: 2019-04-16 14:13 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 18:14:03 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0211 normal SHIPPED_LIVE redhat-support-plugin-rhev bug fix and enhancement update 2015-02-11 23:11:47 UTC

Description Aval 2014-07-04 01:03:42 UTC
Description of problem:RedHat Support plugin for rhev randomly fails to collect sosreports from hypervisors on a customer setup, while running log-collector from command line works well and as desired.


Version-Release number of selected component (if applicable):
RHEV 3.4
redhat-support-plugin-rhev-3.4.0-4.el6ev.noarch


How reproducible:
Randomly, but happens more often than not

Steps to Reproduce:
1.Login to supoort plugin for rhev 
2.Try collecting sosreports for hypervisors
3.

Actual results:
Failing to collect sosreport for hypervisors

Expected results:
It should be able to collect sosreports or report back a meaningful error 

Additional info:

Comment 1 Spenser Shumaker 2014-07-04 17:06:34 UTC
I have seen this problem before when /tmp does not have enough space to hold all of the SOS reports.  When attaching Hypervisor SOS reports the plugin asynchronously runs SOS on the hypervisors, it then transfers each SOS report back to /tmp on the Manger and then uploaded the report to Red Hat. Once uploaded the sos report is deleted.  Due to the large nature of the SOS reports and the fact that multiple are selected, space runs out quickly.

I am currently investigating why the code is not failing in a better way.  An interim solution would be to either add more space to /tmp or upload 1 SOS report at a time.  I will us this bug to track progress on finding a better solution to this bug.

Comment 5 Robert McSwain 2014-08-21 14:11:30 UTC
I've had a customer try this and it seems that we're getting all of the files from the RHEV-M, RHEV-Hs, sos_pgdump.tar, and the timeskew.txt files, but they are all getting uploaded separately rather than being combined into a sosreport-LogCollector file like normal. A RHEV-M + 4 hypervisors leads to 10 files being uploaded to a case. This process did take approximately an hour to start til upload, for what it's worth, so it doesn't seem like a space issue in this case either.

Comment 8 Jiri Belka 2014-09-22 13:49:59 UTC
based on irc discussion

Comment 10 Spenser Shumaker 2014-11-14 20:20:11 UTC
Cause: A timeout was happing during upload of a SOS report.
Consequence: This was resulting in a 500 error displayed on the screen and the user thinking the SOS upload failed.
Fix: The timeout has now been increased to 2 hours.
Result: The plugin now successfully displays the upload status of the SOS reports.

Comment 11 Jiri Belka 2014-11-26 13:24:56 UTC
ok, redhat-support-plugin-rhev-3.5.0-1.el6ev.noarch

see https://access.redhat.com/support/cases/#/case/01302112

Comment 12 Eyal Edri 2014-12-16 10:24:00 UTC
Spenser,
please mark the require_doc_text flag as '-' if any of these bugs needs doc for errata or ? if you need to document it and request assistance from doc team?
this is needed asap for the last rc build due this week.

Comment 14 errata-xmlrpc 2015-02-11 18:14:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0211.html


Note You need to log in before you can comment on or make changes to this bug.