Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1115963 - missing sosreport.html from postgresql-report-admin
Summary: missing sosreport.html from postgresql-report-admin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Simone Tiraboschi
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks: 1119363 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-03 12:09 UTC by Petr Beňas
Modified: 2015-02-11 17:46 UTC (History)
13 users (show)

Fixed In Version: ovirt-3.5.0-beta1.1
Doc Type: Bug Fix
Doc Text:
Sosreport has a command line option (--report) to generate HTML reports of the fetched file, but the command line option list was not correctly handled and the --report option got lost. This caused the generated archive to not include the HTML report. This bug fix corrects the handling of the CLI option list, and the generated archive now includes the HTML report.
Clone Of:
: 1119363 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:46:05 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0193 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2015-02-11 22:35:42 UTC
oVirt gerrit 30028 master MERGED sos: fixing report generation on sos < 3.0 Never
oVirt gerrit 30034 ovirt-log-collector-3.4 MERGED sos: fixing report generation on sos < 3.0 Never
oVirt gerrit 30035 ovirt-log-collector-3.5 MERGED sos: fixing report generation on sos < 3.0 Never

Description Petr Beňas 2014-07-03 12:09:29 UTC
Description of problem:
A HTML file is missing, causing automated tests to fail 

Version-Release number of selected component (if applicable):
av10

How reproducible:
100%

Steps to Reproduce:
1. engine-log-collector collect
2. extract the collected archive 
3. extract the log-collector-data/postgresql-sosreport-admin*.tar.xz

Actual results:
sos_reports directory is empty

Expected results:
sos_reports directory contains the sosreport.html

Additional info:
Works fine on 3.3 and on 3.4 up to av9.6.

Comment 1 Petr Beňas 2014-07-04 08:55:54 UTC
But this bug seems to affect oVirt 3.5 as well.

Comment 4 Petr Beňas 2014-08-27 11:37:56 UTC
in ovirt-log-collector-3.5.0-0.1.master.20140813134850.gitfb987b4.el6.noarch

Comment 8 errata-xmlrpc 2015-02-11 17:46:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0193.html


Note You need to log in before you can comment on or make changes to this bug.