Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1115569 - reports fails to start after installation
Summary: reports fails to start after installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Shirly Radco
QA Contact: movciari
URL:
Whiteboard: infra
Depends On: 1114914
Blocks: 1117190 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-02 15:42 UTC by Tareq Alayan
Modified: 2016-02-10 19:44 UTC (History)
12 users (show)

Fixed In Version: vt1.5 - rhevm-reports-3.5.0-1.el6_5
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1117190 (view as bug list)
Environment:
Last Closed: 2015-02-11 18:17:43 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
sever.log (deleted)
2014-07-02 15:47 UTC, Tareq Alayan
no flags Details
engine.log (deleted)
2014-07-02 15:48 UTC, Tareq Alayan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0176 normal SHIPPED_LIVE rhevm-reports 3.5 bug fix and enhancement update 2015-02-11 23:11:58 UTC
oVirt gerrit 29648 master MERGED packaging: setup: disable Spring integration in JRS pro Never
oVirt gerrit 29700 ovirt-engine-reports-3.4 MERGED packaging: setup: disable Spring integration in JRS pro Never

Description Tareq Alayan 2014-07-02 15:42:03 UTC
Description of problem:
Clean  installtion of engine + reports and dwh 
engine and dwh service are up.
reports portal is unaccessible

Version-Release number of selected component (if applicable):

rhevm-dwh-setup-3.4.1-1.el6ev.noarch
rhevm-reports-3.4.1-1.el6ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. rhevm-setup , make sure that dwh and reports rpms are installed
2.
3.

Actual results:
engine and dwh are up and running 
reports portal is not accessible

Expected results:
all up

Additional info:

Comment 1 Tareq Alayan 2014-07-02 15:47:28 UTC
Created attachment 914235 [details]
sever.log

Comment 2 Tareq Alayan 2014-07-02 15:48:22 UTC
Created attachment 914236 [details]
engine.log

Comment 3 Tareq Alayan 2014-07-02 15:59:39 UTC
log snippet:
============
2014-07-02 18:22:20,799 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015893: Encountered invalid class name 'http\://saxon.sf.net/jaxp
/xpath/om:     net.sf.saxon.xpath.XPathFactoryImpl' for service type 'javax.xml.xpath.XPathFactory'
2014-07-02 18:22:20,944 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC000001: Failed to start service jboss.deployment.unit."ovirt-engine-re
ports.war".DEPENDENCIES: org.jboss.msc.service.StartException in service jboss.deployment.unit."ovirt-engine-reports.war".DEPENDENCIES: JBAS018733: Failed to
 process phase DEPENDENCIES of deployment "ovirt-engine-reports.war"
        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:166) [jboss-as-server.jar:7.4.0.Final-redhat-15]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1980) [jboss-msc.jar:1.1.5.Final-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1913) [jboss-msc.jar:1.1.5.Final-redhat-1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_55]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_55]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_55]
Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: org.jboss.as.server.deployment.DeploymentUnitProcessingException: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011236: No spring integration jar found
        at org.jboss.as.jaxrs.deployment.JaxrsSpringProcessor.deploy(JaxrsSpringProcessor.java:206)
        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:159) [jboss-as-server.jar:7.4.0.Final-redhat-15]
        ... 5 more
Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011236: No spring integration jar found
        at org.jboss.as.jaxrs.deployment.JaxrsSpringProcessor.getResteasySpringVirtualFile(JaxrsSpringProcessor.java:136)
        at org.jboss.as.jaxrs.deployment.JaxrsSpringProcessor.deploy(JaxrsSpringProcessor.java:202)
        ... 6 more
Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011236: No spring integration jar found
        at org.jboss.as.jaxrs.deployment.JaxrsSpringProcessor.getResteasySpringVirtualFile(JaxrsSpringProcessor.java:111)
        ... 7 more

Comment 5 Yaniv Lavi 2014-07-03 08:47:43 UTC
This doesn't make any sense. This is a very basic scenario that has not had any problems in the last months. 
What repos are you using to install?
What jboss version?




Yaniv

Comment 6 Yaniv Lavi 2014-07-03 09:11:50 UTC
You are using a non supported jboss version:
jbossas-standalone-7.4.0 (EAP-6.3.0)

It's no wonder it doesn't work, please make sure you follow the installation instructions for 3.4.


Yaniv

Comment 9 Yaniv Lavi 2014-07-06 12:04:56 UTC
Juan, do you have any insights to way this is happening on the new jboss?



Yaniv

Comment 10 Juan Hernández 2014-07-07 10:42:47 UTC
It looks like during the deployment of the application Resteasy is detecting some Spring beans, and is trying to activate the Resteasy integration support, and that is failing. I think that the reports application shouldn't use the version of Resteasy provided by the application server, as they include their own version (Jersey, I believe), but I thought that they are already excluding the resteasy dependencies.

The Spring integration can be disabled adding this to the web.xml of the application:

  <context-param>
    <param-name>org.jboss.as.jaxrs.disableSpringIntegration</param-name>
    <param-value>true<param-value>
  </context-param>

Comment 11 Juan Hernández 2014-07-07 12:24:53 UTC
Note that the Resteasy/Spring integration was added recently, in EAP 6.3.0 CR1, in order to fix 1019161.

Comment 12 Barak 2014-07-07 12:25:51 UTC
Tarq,

Can you please check whether the workaround suggested in comment #10 works ?

Comment 13 Yaniv Lavi 2014-07-07 14:32:53 UTC
Please add:
  <context-param>
    <param-name>org.jboss.as.jaxrs.disableSpringIntegration</param-name>
    <param-value>true</param-value>
  </context-param>

The previous snippet had a mistake.



Yaniv

Comment 14 Tareq Alayan 2014-07-07 14:37:19 UTC
i added
<context-param>
    <param-name>org.jboss.as.jaxrs.disableSpringIntegration</param-name>
    <param-value>true</param-value>
  </context-param>

to:

/var/lib/ovirt-engine-reports/ovirt-engine-reports.war/WEB-INF/web.xml


and it worked

Comment 16 movciari 2014-07-15 07:56:17 UTC
can't test right now because engine-setup doesn't work with reports: https://bugzilla.redhat.com/show_bug.cgi?id=1114914

Comment 17 Yaniv Lavi 2014-07-24 14:10:53 UTC
Need to test on a vt release. moving to MODIFIED for now.



Yaniv

Comment 20 errata-xmlrpc 2015-02-11 18:17:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0176.html


Note You need to log in before you can comment on or make changes to this bug.