Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1115526 - [windows guest tools] do not overwrite .ini file
Summary: [windows guest tools] do not overwrite .ini file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Windows Guest Tools
Version: 3.4.0
Hardware: All
OS: Windows
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Lev Veyde
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks: 1119801 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-07-02 14:12 UTC by Jiri Belka
Modified: 2015-02-11 17:41 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this enhancement, the RHEV Agent rhev-agent.ini file is no longer replaced each time a new version of the agent is installed. New configuration files were introduced to contain the system configuration, and so the rhev-agent.ini configuration file is now intended to contain user local configuration overrides. Note that users should be aware that as a consequence a broken configuration will remain even after upgrading or removing and then re-installing a software.
Clone Of:
: 1119801 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:41:39 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0198 normal SHIPPED_LIVE rhev-guest-tools-iso bug fix and enhancement update 2015-02-11 22:34:00 UTC

Description Jiri Belka 2014-07-02 14:12:23 UTC
Description of problem:

do not overwrite .ini file dumbly, we have now 'default' and 'default-logger' files in Agent dir, so keep original .ini file. one could change options, rates, log file path... and dumb overwriting is annoying.

Version-Release number of selected component (if applicable):
3.4.8 WGT

How reproducible:
100%

Steps to Reproduce:
1. install WGT which would put 'default' and 'default-logger' onto filesystem (3.4.8)
2. edit init
3. update to newer WGT

Actual results:
overwritten

Expected results:
should keep original ini file, any new config options should go to default/default-logger

Additional info:
3.4.9 is not cooked yet

Comment 3 Jiri Belka 2014-08-29 13:21:59 UTC
ok, 3.5.2 (default* replaces, rhev-agent.ini kept)

Comment 5 errata-xmlrpc 2015-02-11 17:41:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0198.html


Note You need to log in before you can comment on or make changes to this bug.