Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1114909 - kdnssd-avahi build failure ppc64le archi because of loop in deps
Summary: kdnssd-avahi build failure ppc64le archi because of loop in deps
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs3
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-07-01 09:09 UTC by Michel Normand
Modified: 2014-07-22 18:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-22 18:05:00 UTC


Attachments (Terms of Use)

Description Michel Normand 2014-07-01 09:09:47 UTC
Description of problem: kdnssd-avahi build failure ppc64le archi 
because buildrequires kdelibs3-devel that requires kdnssd-devel
and kdnssd-devel itself provided by kdnssd-avahi-devel

Version-Release number of selected component (if applicable):
kdnssd-avahi-0.1.3-0.19.20080116svn.fc21

Steps to Reproduce:
1. fedpkg clone -a kdnssd-avahi
2. fedpkg mockbuild

Actual results:
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=238553
DEBUG util.py:282:  Error: Package: kdelibs3-devel-3.5.10-59.fc21.ppc64le (build)
DEBUG util.py:282:             Requires: libkdnssd-devel

Additional info:
I do not know how to handle such loop problem in the requirements between kdnssd-avahi and kdelibs3-devel

Are we able to temporarily create a bootstrap build in koji for one of the two packages ?

Comment 1 Rex Dieter 2014-07-01 13:29:14 UTC
Yeah, bootstrap kdelibs3.  

step 1, 
in kdelibs3.spec find:
%if 0%{?fedora}
%define libkdnssd libkdnssd
%endif

and comment out the %define, build kdelibs3

2.  build kdnssd-avahi
3.  put kdelibs3 back the way it was, build as usual.


Do you need any help doing this?

Comment 2 Michel Normand 2014-07-01 14:18:50 UTC
(In reply to Rex Dieter from comment #1)
> Yeah, bootstrap kdelibs3.  
> 
> step 1, 
> in kdelibs3.spec find:
> %if 0%{?fedora}
> %define libkdnssd libkdnssd
> %endif
> 
> and comment out the %define, build kdelibs3
> 
> 2.  build kdnssd-avahi
> 3.  put kdelibs3 back the way it was, build as usual.
> 
> 
> Do you need any help doing this?

Yes, because I do not think I have the right to make spec changes in fedora db.

Comment 3 Rex Dieter 2014-07-02 13:43:31 UTC
Submitted a bootstrap build here,
http://ppc-le.koji.fedoraproject.org/koji/taskinfo?taskID=82254

Comment 4 Michel Normand 2014-07-02 14:15:52 UTC
(In reply to Rex Dieter from comment #3)
> Submitted a bootstrap build here,
> http://ppc-le.koji.fedoraproject.org/koji/taskinfo?taskID=82254

the ppc64le builds should now be done in ppc.koji hub and not anymore in ppc-le.koji that do not have any associated builder anymore.

Comment 5 Rex Dieter 2014-07-02 14:29:38 UTC
Ah, once more with feeling:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1925181

Comment 6 Rex Dieter 2014-07-03 12:27:07 UTC
Looks like build failed due to buildroot broken dependencies,
DEBUG util.py:282:  Error: Package: cups-filters-1.0.53-3.fc21.ppc64le (build)
DEBUG util.py:282:             Requires: libpoppler.so.43()(64bit)

but cups-filters was rebuilt since then, so trying again:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1928160

Comment 7 Rex Dieter 2014-07-03 12:55:57 UTC
I guess I'm confused, cups-filters-1.0.54-1.fc21 was built successfully jul 01:
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=248075

and,
$ ppc-koji latest-pkg rawhide cups-filters
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
cups-filters-1.0.54-4.fc21                f21                   michelmno

But I'm still getting broken deps referencing something older:
DEBUG util.py:282:  Error: Package: cups-filters-1.0.53-3.fc21.ppc64le (build)
DEBUG util.py:282:             Requires: libpoppler.so.43()(64bit)

Comment 8 Rex Dieter 2014-07-03 12:56:46 UTC
I messed up the version references there, but hopeufully you can still see my point. :)

Comment 9 Rex Dieter 2014-07-07 16:13:56 UTC
Still seeing broken deps per comment #7 on ppc64le today.  Don't see any bugs on the PPC64LETracker that seem to mention poppler or cups-filters, should I file one?

Comment 10 Michel Normand 2014-07-22 15:30:41 UTC
 kdnssd-avahi now succeeded at task Id for release f21.
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1958947

So we should now remove the bootstrap change of kdelibs3.

Comment 11 Rex Dieter 2014-07-22 18:05:00 UTC
OK, great.

kdelibs.spec:
%changelog
* Tue Jul 22 2014 Rex Dieter <rdieter@fedoraproject.org> 3.5.10-61
- drop bootstrap


Note You need to log in before you can comment on or make changes to this bug.