Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1113991 - dyninst build failure on ppc64le archi
Summary: dyninst build failure on ppc64le archi
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dyninst
Version: 22
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: William Cohen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-06-27 12:10 UTC by Michel Normand
Modified: 2015-08-13 16:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-13 16:49:16 UTC


Attachments (Terms of Use)
dyninst.ppc64le_ABIv2.patch (deleted)
2014-06-27 12:11 UTC, Michel Normand
no flags Details | Diff

Description Michel Normand 2014-06-27 12:10:39 UTC
Description of problem: dyninst build failure on ppc64le archi
as reported by http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1902638

Version-Release number of selected component (if applicable):
dyninst-8.1.2-9.fc21

How reproducible:


Steps to Reproduce:
1. fedpkg clone -a dyninst
2. fedpkg mockbuild

Actual results:
===                  
gcc  -L../../../ppc64_linux/lib  -Wl,-soname,libdyninstAPI_RT.so.8.1 -o libdyninstAPI_RT.so.8.1.2 V_libdyninstAPI_RT.o RTposix.o RTlinux.o RTheap.o RTheap-linux.o RTthread.o RTthread-powerpc.o RTstatic_ctors_dtors-ppc64.o RTcommon.o RTmemEmulator.o RTsignal.o RTthread-powerpc-asm.o RTspace.o -Wl,-z,relro  -m64 -m64 -shared -ldl 
/usr/bin/ld: RTthread-powerpc-asm.o: ABI version 1 is not compatible with ABI version 2 output
/usr/bin/ld: failed to merge target specific data of file RTthread-powerpc-asm.o                  
===


Additional info:
With the dyninst.ppc64le_ABIv2.patch provided as attachment able to scratch build on koji:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1905772

Comment 1 Michel Normand 2014-06-27 12:11:49 UTC
Created attachment 912793 [details]
dyninst.ppc64le_ABIv2.patch

Comment 2 Josh Stone 2014-06-30 18:07:17 UTC
I presume this only fixes the *build* for ppc64le - have you tried running anything?  Dyninst is the sort of package that needs specific architectural knowledge, so I doubt it will work on LE without further changes.  (In fact, next time I rebase the package I intend to flip the spec's ExcludeArch to an ExclusiveArch, because a whitelist makes more sense in this case.)

Comment 3 Michel Normand 2014-07-01 07:11:38 UTC
(In reply to Josh Stone from comment #2)
> I presume this only fixes the *build* for ppc64le - have you tried running
> anything?  Dyninst is the sort of package that needs specific architectural
> knowledge, so I doubt it will work on LE without further changes.  (In fact,
> next time I rebase the package I intend to flip the spec's ExcludeArch to an
> ExclusiveArch, because a whitelist makes more sense in this case.)

you are right, I only tried a build that was in the list of failed in mass rebuild on ppc64le.

Comment 4 Jaroslav Reznik 2015-03-03 16:04:37 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 5 Rafael Fonseca 2015-08-13 15:26:16 UTC
dyninst is now arch-exclusive. Can we close this bug?

Comment 6 Josh Stone 2015-08-13 16:49:16 UTC
Yeah, we can close it.  If anyone wants ppc64le support, they should work upstream.


Note You need to log in before you can comment on or make changes to this bug.