Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1113694 - [redhat-support-plugin-rhev] Not able to reduce the log level of the plugin
Summary: [redhat-support-plugin-rhev] Not able to reduce the log level of the plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev
Version: 3.3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Spenser Shumaker
QA Contact: Jiri Belka
URL:
Whiteboard: subeng
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-26 16:39 UTC by Javier Coscia
Modified: 2018-12-06 17:02 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the log level for the plugin could not be configured. This caused extremely verbose output to be logged. Now, the log level can be configured in "/etc/ovirt-engine/redhatsupportplugin-config/logging.properties".
Clone Of:
Environment:
Last Closed: 2015-02-11 18:13:58 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 971833 None None None Never
Red Hat Product Errata RHBA-2015:0211 normal SHIPPED_LIVE redhat-support-plugin-rhev bug fix and enhancement update 2015-02-11 23:11:47 UTC

Description Javier Coscia 2014-06-26 16:39:41 UTC
Description of problem:

Ability to reduce the log level of the redhat-support-plugin-rhev in RHEV-M

Version-Release number of selected component (if applicable):

rhevm-setup-plugins-3.3.1-1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install/enable the rhev support plugin in RHEV 3.3
2. 
3.

Actual results:

In a few hours the file has rotated several times

Expected results:

One should be able to change the log level of the plugin either by changing configuration in /etc/ovirt-engine/redhatsupportplugin.conf and/or through the RHEV-M GUI

Additional info:

Comment 2 Spenser Shumaker 2014-06-30 20:00:58 UTC
An immediate solution is to modify the logging.properties file located in the redhat-support-plugin-rhev-war.war

-"vim /usr/share/ovirt-engine/redhat-support-plugin-rhev-ear-3.4.0.ear/redhat-support-plugin-rhev-war.war"
-Move cursor to "WEB-INF/logging.properties" and press enter
-Change desired logging level.
-save and quit
-Restart ovirt-engine

I am working on a fix that moves the logging config file outside of the war package so it is more easily configurable.

Comment 5 Jiri Belka 2014-09-19 09:49:31 UTC
hm, why do i see DEBUG level if 'logging.properties' defines INFO? it seems inaccurate for me.

# rpm -qa redhat-support\*
redhat-support-plugin-rhev-3.5.0-0.el6ev.noarch

# grep DEBUG /var/log/ovirt-engine/redhat-support-plugin-rhev.log | tail
DEBUG Fri Sep 19 11:01:53.542 CEST 2014 [duler_Worker-60] [SimpleThreadPool         ] WorkerThread is shut down.
DEBUG Fri Sep 19 11:01:53.543 CEST 2014 [duler_Worker-92] [SimpleThreadPool         ] WorkerThread is shut down.
DEBUG Fri Sep 19 11:01:53.543 CEST 2014 [duler_Worker-56] [SimpleThreadPool         ] WorkerThread is shut down.
DEBUG Fri Sep 19 11:01:53.544 CEST 2014 [duler_Worker-47] [SimpleThreadPool         ] WorkerThread is shut down.
DEBUG Fri Sep 19 11:01:53.544 CEST 2014 [duler_Worker-15] [SimpleThreadPool         ] WorkerThread is shut down.
DEBUG Fri Sep 19 11:01:53.545 CEST 2014 [duler_Worker-76] [SimpleThreadPool         ] WorkerThread is shut down.
DEBUG Fri Sep 19 11:01:53.545 CEST 2014 [eduler_Worker-8] [SimpleThreadPool         ] WorkerThread is shut down.
DEBUG Fri Sep 19 11:01:53.545 CEST 2014 [uler_Worker-100] [SimpleThreadPool         ] WorkerThread is shut down.
DEBUG Fri Sep 19 11:01:53.627 CEST 2014 [vice thread 1-1] [repository               ] ContentRepository stopped
DEBUG Fri Sep 19 11:01:53.628 CEST 2014 [read Pool -- 92] [server                   ] DeploymentMountProvider stopped

# cat /etc/ovirt-engine/redhatsupportplugin-config/logging.properties
# Root logger option
log4j.rootCategory=INFO, redhat_access_plugin

! LOG TO A FILE
log4j.appender.redhat_access_plugin=org.apache.log4j.RollingFileAppender
log4j.appender.redhat_access_plugin.layout=org.apache.log4j.PatternLayout
log4j.appender.redhat_access_plugin.layout.ConversionPattern=%-5p %d{EEE MMM dd HH:mm:ss.SSS zzz yyyy} [%-15.15t] [%-25.25c{1}] %m%n

! Specify the file name
log4j.appender.redhat_access_plugin.File=/var/log/ovirt-engine/redhat-support-plugin-rhev.log

! Control the maximum log file size
log4j.appender.redhat_access_plugin.MaxFileSize=3000KB
log4j.appender.redhat_access_plugin.MaxBackupIndex=3

Comment 6 Spenser Shumaker 2014-09-19 12:23:27 UTC
I am unable to reproduce these results.  And this is working as designed.  Could the DEBUG messages be from before upgrading to the latest version of the plugin?

Comment 7 Jiri Belka 2014-09-22 11:50:02 UTC
ok, probably above issues were from before update as i can't see DEBUG lines anymore.

redhat-support-plugin-rhev-3.5.0-0.el6ev.noarch

Comment 8 Spenser Shumaker 2014-11-14 20:18:43 UTC
Cause: The log level for the plugin was default set to DEBUG.
Consequence: This caused a lot of unnecessary logging to the log file.
Fix: Set default log level to INFO.
Result: The plugin no longer logs unnecessary lines.

Comment 9 Eyal Edri 2014-12-16 10:23:57 UTC
Spenser,
please mark the require_doc_text flag as '-' if any of these bugs needs doc for errata or ? if you need to document it and request assistance from doc team?
this is needed asap for the last rc build due this week.

Comment 11 errata-xmlrpc 2015-02-11 18:13:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0211.html


Note You need to log in before you can comment on or make changes to this bug.