Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 111355 - Xserver will not initiate on system startup with PowerVR driver
Summary: Xserver will not initiate on system startup with PowerVR driver
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Fedora
Classification: Fedora
Component: XFree86
Version: rawhide
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-02 15:51 UTC by Bernard Stetz
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:15 UTC


Attachments (Terms of Use)
XFree86 startup log (deleted)
2003-12-02 15:54 UTC, Bernard Stetz
no flags Details
X Config file (deleted)
2003-12-02 15:55 UTC, Bernard Stetz
no flags Details

Description Bernard Stetz 2003-12-02 15:51:59 UTC
Description of problem:
On system start-up, Xserver will not start and reports a Interrupt 11
error. However, if you start the server manually, i.e. after a login
and issue a startx, the Xserver operates normally.


Version-Release number of selected component (if applicable):
Latest Xfree86

How reproducible:
Compile the latest powervr module for a Kyro chip set. Change
XF86Config to reflect the new loaded module. Do a system boot and the
Xserver will not start.

Steps to Reproduce:
1. See above. Also note that this happens with Run Level 5.
2.
3.
  
Actual results:
Will not start Xserver. View of log indicates Interrupt 11 error.

Expected results:
System should startup, for run level 5, in graphics mode.

Additional info:
This worked in RH 9.0 and previous versions (RH 8 and RH 7.x)

Comment 1 Bernard Stetz 2003-12-02 15:54:20 UTC
Created attachment 96282 [details]
XFree86 startup log

Comment 2 Bernard Stetz 2003-12-02 15:55:13 UTC
Created attachment 96283 [details]
X Config file

Comment 3 Mike A. Harris 2003-12-02 16:47:16 UTC
This bug report is invalid for several reasons:

1) We do not support proprietary video drivers or other 3rd party
   drivers.

2) We do not support proprietary kernel modules or systems which are
   using proprietary kernel modules.

3) The bug is filed against Fedora Core test2, and now that Fedora
   Core 1 is officially released, test2 is obsolete, and we do not
   accept bug reports against it.

You will have to contact PowerVR or whoever supplied the drivers
to you for technical support assistance for this problem.

Closing as duplicate of our master "binonly" dupe bug.

*** This bug has been marked as a duplicate of 78616 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:00:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.