Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1113512 - voms_mysql_plugin build fail for ppc64le archi needs mariadb-devel
Summary: voms_mysql_plugin build fail for ppc64le archi needs mariadb-devel
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: voms-mysql-plugin
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-06-26 10:33 UTC by Michel Normand
Modified: 2014-06-26 14:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-26 14:53:44 UTC


Attachments (Terms of Use)

Description Michel Normand 2014-06-26 10:33:07 UTC
Description of problem: 
voms_mysql_plugin build fail for ppc64le archi needs mariadb-devel


Version-Release number of selected component (if applicable):
voms-mysql-plugin-3.1.6-6.fc21

How reproducible:


Steps to Reproduce:
1. fedpkg clone -a voms-mysql-plugin
2. fedpkg srpm
3. fedpkg mockbuild

Actual results:
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=239284
root.log extract:
===
DEBUG util.py:282:  Getting requirements for voms-mysql-plugin-3.1.6-6.fc21.src
DEBUG util.py:282:   --> libtool-2.4.2-24.fc21.ppc64le
DEBUG util.py:282:   --> 1:openssl-1.0.1h-1.fc21.ppc64le
DEBUG util.py:282:  Error: No Package found for mysql-devel
DEBUG util.py:372:  Child return code was: 1
===


Additional info:
The proposal is to change a buildrequires line as suggested below:

diff --git a/voms-mysql-plugin.spec b/voms-mysql-plugin.spec
index 7f66733..bcbb700 100644
--- a/voms-mysql-plugin.spec
+++ b/voms-mysql-plugin.spec
@@ -18,7 +18,7 @@ Provides:     voms-mysql = %{version}-%{release}
 Obsoletes:     voms-mysql < 3.1.6
 Requires:      voms-server%{?_isa}
 BuildRequires: libtool
-BuildRequires: mysql-devel
+BuildRequires: mariadb-devel
 BuildRequires: openssl
 
 %description

Comment 1 Mattias Ellert 2014-06-26 14:53:44 UTC
This does not make sense. The mariadb-devel package provides mysql-devel, so if mariadb-devel is available it should satisfy the BR. Infact, when building the package in koji for the primary archs, yum resolves the BR to mariadb-devel.

$ rpm -q --whatprovides mysql-devel
mariadb-devel-10.0.12-2.fc21.x86_64

http://ppc.koji.fedoraproject.org/koji/rpminfo?rpmID=1692158

This should work just fine for ppc64le too. If it does not there is something broken in the ppc koji or the ppc64le koji buildroot.


Note You need to log in before you can comment on or make changes to this bug.