Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1113003 - foreman-integration: sign host as foreman's
Summary: foreman-integration: sign host as foreman's
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Yaniv Bronhaim
QA Contact: movciari
URL:
Whiteboard:
Depends On: 1165208
Blocks: rhev3.5beta 1156165 1185605
TreeView+ depends on / blocked
 
Reported: 2014-06-25 09:01 UTC by Yaniv Bronhaim
Modified: 2016-04-20 01:35 UTC (History)
7 users (show)

Fixed In Version: ovirt-engine-backend-3.6.0-0.0.master.20150412172306.git55ba764
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1185605 (view as bug list)
Environment:
Last Closed: 2016-04-20 01:35:23 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30059 master MERGED core: add host_provider_id to vdsStatic Never
oVirt gerrit 31103 ovirt-engine-3.5 MERGED core: add host_provider_id to vdsStatic Never
oVirt gerrit 37108 master MERGED Due to commit a276f142 foreman id is not provided in vds static table Never
oVirt gerrit 37113 ovirt-engine-3.5 MERGED Due to commit a276f142 foreman id is not provided in vds static table Never

Description Yaniv Bronhaim 2014-06-25 09:01:25 UTC
Currently we thought to sign the host as part of vdsStatic fields. It will allow to recognize the host as managed by foreman and gather more information about its configuration status

Comment 1 Oved Ourfali 2014-06-29 06:50:26 UTC
(In reply to Yaniv Bronhaim from comment #0)
> Currently we thought to sign the host as part of vdsStatic fields. It will
> allow to recognize the host as managed by foreman and gather more
> information about its configuration status

I'd suggest to add the host_provider_id field to vdsStatic in order to accomplish that.

Comment 2 Petr Beňas 2014-11-11 11:56:28 UTC
This looks like a code change and it seems there is nothing to be tested here. If you think otherwise, please provide steps to reproduce.

Comment 3 Yaniv Bronhaim 2014-11-11 13:24:57 UTC
testcase:
Go to engine, add host by external provider.
check the provider id in db (select * from providers) and check that the value correlates to the value in vds_static::host_provider_id (select host_provider_id from vds_static;)

except that, check that host which added regularly gets none in its host_provider_id column.

Comment 4 movciari 2015-01-19 17:13:08 UTC
host_provider_id is empty in vds_static:
select vds_name,host_provider_id from vds_static ;
 vds_name | host_provider_id 
----------+------------------
 host1    | 
(1 row)


Note You need to log in before you can comment on or make changes to this bug.