Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1112779 - Iterating mounts can take a few seconds
Summary: Iterating mounts can take a few seconds
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Dima Kuznetsov
QA Contact: Jiri Belka
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-24 16:24 UTC by Dima Kuznetsov
Modified: 2016-02-10 19:31 UTC (History)
9 users (show)

Fixed In Version: vt3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 13:40:28 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 28586 master MERGED mounts: Optimize mount loop device resolution Never
oVirt gerrit 32535 ovirt-3.5 MERGED mounts: Optimize mount loop device resolution Never
oVirt gerrit 33833 ovirt-3.5 MERGED mount: fix _loopFsSpecsTimestamp global definition Never

Description Dima Kuznetsov 2014-06-24 16:24:47 UTC
Description of problem:
On hosts with large amount of mounts, iterating active mounts can lead to big delays, because for each mount encountered, all active mounts are checked.

Version-Release number of selected component (if applicable):
4.15


How reproducible:
100%, tests reproducing the behavior provided in patch.


Steps to Reproduce:
1. Have about 1000 mounts
2. call some code that iterates mounts

Actual results:
With tests provided, for 1000 mount entries, iteration took 11 second

Expected results:
After adding caching, iteration reduced to 0.1 seconds.


Additional info:

Comment 1 Eyal Edri 2014-09-10 20:21:40 UTC
fixed in vt3, moving to on_qa.
if you believe this bug isn't released in vt3, please report to rhev-integ@redhat.com

Comment 2 Jiri Belka 2014-10-02 16:40:14 UTC
ok, vdsm-4.14.17-1.el6ev.x86_64

`time vdsClient -s 0 getStorageDomainsList' is always OK, also CPU usage is low.


Note You need to log in before you can comment on or make changes to this bug.