Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1112616 - Fix Ad Hoc Statistics domain according to the new users table
Summary: Fix Ad Hoc Statistics domain according to the new users table
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Shirly Radco
QA Contact: Petr Matyáš
URL:
Whiteboard: infra
Depends On: 1149446
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-24 10:41 UTC by Shirly Radco
Modified: 2016-02-10 19:42 UTC (History)
9 users (show)

Fixed In Version: vt1.5 - rhevm-reports-3.5.0-1.el6_5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 18:17:39 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0176 normal SHIPPED_LIVE rhevm-reports 3.5 bug fix and enhancement update 2015-02-11 23:11:58 UTC

Description Shirly Radco 2014-06-24 10:41:05 UTC
Description of problem:

Fix Ad Hoc statistics domain according to the new users table.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Choose statistics domain
2.choose VM -> Users Usage
3.pick reports (Table/Cross tab /..)
4.Try to add User Name to the report 

Actual results:
Error

Expected results:
The domain should be fully working

Additional info:

Comment 2 Yaniv Lavi 2014-07-22 13:53:14 UTC
Please add the patch to the bug.



Yaniv

Comment 4 Petr Matyáš 2014-10-02 10:49:54 UTC
I'm unable to test this or I'm doing something wrong, because I can't view any Adhoc report. I get only this: Your license doesn't allow access to the Ad Hoc Designer.

Comment 7 Petr Matyáš 2014-10-23 13:48:04 UTC
I suppose I should be able to see statistics for other users that lunched VM and not just admin? And I don't see any option to add them manually only if you meant to add them only access permissions.

Comment 8 Shirly Radco 2014-10-26 11:04:05 UTC
(In reply to Petr Matyáš from comment #7)
> I suppose I should be able to see statistics for other users that lunched VM
> and not just admin? And I don't see any option to add them manually only if
> you meant to add them only access permissions.

You can use eng.lab active directory to add users to the admin portal.

./engine-manage-domains add --domain=qa.lab.tlv.redhat.com --user=vdcadmin --provider=ad

123456

Please ask which user you can use for testing.

Comment 9 Petr Matyáš 2014-10-27 13:21:49 UTC
I didn't explain this properly, I have the active directory (using user "John1"). User created VM and launched it, but I can't see it in reports, all I see are VMs that admin launched.

Comment 10 Shirly Radco 2014-11-02 15:34:48 UTC
Hi,

Please use "Full Data". You probably used "Sample Data".

Shirly

Comment 11 Petr Matyáš 2014-11-03 10:09:41 UTC
When I switch to "Full data" it makes no difference. I can see VMs that the user created, but I don't see his name next to it, there are just blank fields.

Comment 12 Shirly Radco 2014-11-04 09:59:02 UTC
Work with the user and wait for daily aggregation in order to see the users usage.

Comment 14 errata-xmlrpc 2015-02-11 18:17:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0176.html


Note You need to log in before you can comment on or make changes to this bug.