Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1112612 - BR45 - Fix report according to the new users table
Summary: BR45 - Fix report according to the new users table
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.5.0
Assignee: Shirly Radco
QA Contact: movciari
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-24 10:32 UTC by Shirly Radco
Modified: 2016-02-10 19:06 UTC (History)
8 users (show)

Fixed In Version: oVirt Beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 18:17:35 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0176 normal SHIPPED_LIVE rhevm-reports 3.5 bug fix and enhancement update 2015-02-11 23:11:58 UTC
oVirt gerrit 29370 master MERGED reports: updated br45 report query Never

Description Shirly Radco 2014-06-24 10:32:15 UTC
Description of problem:
BR45 - is broken and should be update according to the new users table that was added.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 movciari 2014-09-02 15:48:37 UTC
ovirt-engine-reports-3.5.0-0.7.el6.noarch
user's first name and last name are not in report, only his username

Comment 3 Shirly Radco 2014-09-03 06:19:36 UTC
This is by design. We kept previouse report same as it was before.
The user first and last name are kept in the database for api and ad hoc reports for know.
Adding them to the report will require a new bug . You can open a new one if you think it is needed.

Comment 4 Shirly Radco 2014-09-03 06:21:49 UTC
The update was to the user_name because we added the users table and added a join to it.

Comment 5 movciari 2014-09-08 14:26:26 UTC
on vt2.2 i see user name but since user_details_history contains his first name and last name, these should be in report too, not just his username

Comment 6 Yaniv Lavi 2014-09-08 14:29:58 UTC
(In reply to movciari from comment #5)
> on vt2.2 i see user name but since user_details_history contains his first
> name and last name, these should be in report too, not just his username

Please read comment #3.

Comment 8 errata-xmlrpc 2015-02-11 18:17:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0176.html


Note You need to log in before you can comment on or make changes to this bug.