Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1112221 - No link to VMs sub-collections under affinitygroups
Summary: No link to VMs sub-collections under affinitygroups
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Gilad Chaplik
QA Contact: Artyom
URL:
Whiteboard: sla
Depends On:
Blocks: 1128461 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-23 11:11 UTC by Artyom
Modified: 2016-02-10 20:16 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.5.0-beta1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1128461 (view as bug list)
Environment:
Last Closed: 2015-02-17 17:16:41 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29400 master MERGED restapi: missing vms link under affinity groups Never

Description Artyom 2014-06-23 11:11:32 UTC
Description of problem:
No element vms under affinity group in api.xsd, because it get_link() on affinity_group return [].

Version-Release number of selected component (if applicable):
av9.6

How reproducible:
Always

Steps to Reproduce:
1. Via python sdk receive some <ovirtsdk.infrastructure.brokers.ClusterAffinityGroup object at 0x3181cd0> object and try to receive affinityGroup links via get_link()
2.
3.

Actual results:
[]

Expected results:
[<Some Object Of type Link>]

Additional info:

Comment 2 Juan Hernández 2014-06-30 10:59:09 UTC
The fix has been merged upstream, so it will be available with the next rebase.

Comment 4 Artyom 2014-07-25 05:38:16 UTC
Verified on ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch

Comment 7 Eyal Edri 2015-02-17 17:16:41 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.