Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1111923 - cpu.current.guest is missing from statistics
Summary: cpu.current.guest is missing from statistics
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: ---
: 3.4.3
Assignee: Martin Sivák
QA Contact: Lukas Svaty
URL:
Whiteboard: sla
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-06-22 08:15 UTC by Ohad Basan
Modified: 2016-02-10 20:15 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-01 16:35:29 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)

Description Ohad Basan 2014-06-22 08:15:39 UTC
Description of problem:
Engine returns cpu.current.guest: -1.0 regardless of what the expected value should be
Here is a comparison between a successful tests (previous test) and a failing test (current one)

PASS:
====
<statistic href="/api/vms/bf58fe0b-72ff-44d9-8e32-c57292fed951/statistics/ef802239-b74a-329f-9955-be8fea6b50a4" id="ef802239-b74a-329f-9955-be8fea6b50a4">
        <name>cpu.current.guest</name>
        <description>CPU used by guest</description>
        <values type="DECIMAL">
            <value>
                <datum>1</datum>
            </value>
        </values>
        <type>GAUGE</type>
        <unit>PERCENT</unit>
        <vm href="/api/vms/bf58fe0b-72ff-44d9-8e32-c57292fed951" id="bf58fe0b-72ff-44d9-8e32-c57292fed951"/>
    </statistic>

Fail:
====
    <statistic href="/api/vms/46649264-1c80-4798-81fb-1c9ff1048da6/statistics/ef802239-b74a-329f-9955-be8fea6b50a4" id="ef802239-b74a-329f-9955-be8fea6b50a4">
        <name>cpu.current.guest</name>
        <description>CPU used by guest</description>
        <values type="DECIMAL">
            <value>
                <datum>-1</datum>
            </value>
        </values>
        <type>GAUGE</type>
        <unit>PERCENT</unit>
        <vm href="/api/vms/46649264-1c80-4798-81fb-1c9ff1048da6" id="46649264-1c80-4798-81fb-1c9ff1048da6"/>
    </statistic>

Comment 4 Omer Frenkel 2014-06-22 12:21:17 UTC
i do see that  vmGetStats return a negative value for cpuUser but i don't see any error in the log, except this Timeout right before, that i'm not sure if related:

VM Channels Listener::DEBUG::2014-06-20 15:47:50,642::vmChannels::91::vds::(_handle_timeouts) Timeout on fileno 7.
Thread-485::DEBUG::2014-06-20 15:47:51,146::BindingXMLRPC::975::vds::(wrapper) client [10.35.19.9]::call vmGetStats with ('46649264-1c80-479
8-81fb-1c9ff1048da6',) {}
Thread-485::DEBUG::2014-06-20 15:47:51,147::BindingXMLRPC::982::vds::(wrapper) return vmGetStats with {'status': {'message': 'Done', 'code': 0}, 'statsList': [{'status': 'Up', 'username': 'Unknown', 'memUsage': '0', 'acpiEnable': 'true', 'guestFQDN': '', 'pid': '11049', 'displayIp': '0', 'displayPort': u'5900', 'session': 'Unknown', 'displaySecurePort': u'5901', 'timeOffset': '0', 'hash': '-6018971317197126644', 'balloonInfo': {'balloon_max': '1048576', 'balloon_target': '1048576', 'balloon_cur': '1048576', 'balloon_min': '1048576'}, 'pauseCode': 'NOERR', 'clientIp': '', 'kvmEnable': 'true', 'network': {}, 'vmId': '46649264-1c80-4798-81fb-1c9ff1048da6', 'displayType': 'qxl', 'cpuUser': '-0.50', 'disks': {u'hdc': {'readLatency': '0', 'apparentsize': '0', 'writeLatency': '0', 'flushLatency': '0', 'readRate': '0.00', 'truesize': '0', 'writeRate': '0.00'}, u'hda': {'readLatency': '73217', 'apparentsize': '197120', 'writeLatency': '0', 'imageID': 'b2c46e32-edc5-45a3-a169-c3c41010f0ef', 'flushLatency': '0', 'readRate': '8.52', 'truesize': '143360', 'writeRate': '0.00'}}, 'monitorResponse': '0', 'statsAge': '1.04', 'elapsedTime': '61', 'vmType': 'kvm', 'cpuSys': '1.27', 'appsList': [], 'guestIPs': ''}]}

libvirt log from this time is missing on the host..
doesn't seem like a blocker.

Comment 5 Michal Skrivanek 2014-06-22 15:35:51 UTC
(Sys/user cpu calculation is SLA)

Comment 6 Doron Fediuck 2014-06-23 08:08:55 UTC
Martin,
is this related to the bug you found (due to recent changes)?

Comment 7 Gilad Chaplik 2014-06-23 11:01:35 UTC
(In reply to Doron Fediuck from comment #6)
> Martin,
> is this related to the bug you found (due to recent changes)?

There were some changes added in NUMA-support for CPU REST modeling, likely that it's related.

Comment 8 Doron Fediuck 2014-06-23 14:18:44 UTC
Ohad,
are you sure this is 3.3?

Also, what is the guest agent version? vdsm version?

Comment 9 Ohad Basan 2014-06-23 14:44:40 UTC
yes. this is 3.3 for sure
vdsm was built from git
4.13.4-40.git0adbd7d
Regarding to the guest agent version , this is configured in qe's cobbler
they might be able to provide more info

Comment 10 Ondra Machacek 2014-06-26 11:16:44 UTC
Vm 'restvm_basic_operations' doesn't have guest agent installed.
It even doesn't have OS installed.

Comment 12 Martin Sivák 2014-08-20 13:28:26 UTC
Is this still happening? I can't reproduce it in my setup and we get the number directly from libvirt.

Comment 13 Ohad Basan 2014-09-01 11:46:45 UTC
doesn't happen anymore.

Comment 14 Doron Fediuck 2014-09-01 16:35:29 UTC
Closing per comment 13.


Note You need to log in before you can comment on or make changes to this bug.